Configuration of SPA 3102 Help

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View



 Hello, all.

 I was hoping to find some help configuring my now Linksys SPA 3102 VOIP
ATA/router.

 My goal is to be able to have an incoming call from a specific number be
forwarded to voicemail (VM) while all other numbers ring through
normally. Thanks to the users of this newsgroup I went with buying the
above mentioned VOIP product.

 For my voicemail service in the long term I plan on getting an older
computer used and installing Asterisk Now or some-such. I can get help
with that down the road. In the short term I may simply sign up with an
SIP provider and get an account that has voicemail included.

 What I would like to be educated on is how to send the appropriate phone
number to the voicemail system.

 For the example let us say the number I want forward to VM is 420-0000.
Where I live we use 7 digit dialing. The area is code is 902.


As part of the web page interface for the SPA3102 there is a page found
at http://192.168.0.84/voice/advanced . It can be reached by following the
"Voice" hyperlink then following the "User 1" hyperlink. There is a
section labelled "Selective Call Forward Settings". Under this section
there is a line with the setting pairs of "Cfwd Sel1 Caller:" and "Cfwd
Sel1 Dest:".

 Is so simple as to just put in the number I want forwarded in "Cfwd Sel1
Caller:"? Is that simple? If not, could someone please advise what I
should be doing.

 Under "Cfwd Sel1 Dest:" should I just put a SIP phone number I am given
by my SIP VOIP provider? (If I were to build my own server would I change
this to an IP address?)

 It would be great if I signed up with someone who gave me a VoIP phone
number of say 999-999-9999 and all I had to do was enter:

Selective Call Forward Settings
Cfwd Sel1 Caller: 9024200000        Cfwd Sel1 Dest: 9999999999


 Seems too easy, and I just do not know what I am doing. Every bit of
info I found was how to configure the SPA 3102 to place outgoing calls.
Help is appreciated.

 Thank you.

Re: Configuration of SPA 3102 Help



 OK, upon reflection and further digging around I am speculating that
perhaps the settings for this goal are under "Voice", "PSTN User", "PSTN-
To-VoIP Selective Call Forward Settings".

It can't be as simple as filling out "Cfwd Sel1 Caller: 902420000" and
"Cfwd Sel1 Dest: sipphonenumber" although it would be great if it was
that easy. Still apreciate info on the subject because as I said all the
info out there is about configuration of outgoing calls.

Re: Configuration of SPA 3102 Help



John McKenzie;191164 Wrote:
> OK, upon reflection and further digging around I
am speculating that
Quoted text here. Click to load it

Yeah, it is a great info as, i am finding a way out to know the proper
configuration of outgoing calls. As, all the settings are required to
be done
accordingly.

Thanks




--
namratasnv

Re: Configuration of SPA 3102 Help



 My problem continues, however I have made progress and thought I should
share the information of what I did and how far it got me. Again,
remember when reading this the problem is not solved, see below for
details as to what has been accomplished and the side effects.


 I am working under the "PSTN User" tab.

 For the  "Cfwd Sel1 Caller:" field I put the name and number of the
desired selectee. So as an example, say the person I want to select is
Alan Turing calling me from 902-444-4444. In "Cfwd Sel1 Caller:" I would
put "Turing, A 444-4444" without the quotes.

 Please note that 7 digit calling is normal for my area and the local
calls coming in that I wanted to select show 7 digits on the caller ID.

 The exact name and format was determined by visiting the "Info" tab and
looking at "Last PSTN Caller:". In fact I copied and pasted the info from
that field. Obviously, 'Turing' called me earlier so the SPA 3102 had the
info under Last PSTN Caller.

 The "Cfwd Sel1 Dest:" field is filled out with the VoIP number I want to
forward to in a format that has the number followed by an at symbol and
the IP address with port. I assume this is overkill, but do not know.
Perhaps the port is not needed if the default is used for example. Say my
VoIP number is 902 555-1212 and my VoIP provider is 200.200.200.200. My
VoIP provider does use a default port of 5060. In the "Cfwd Sel1 Dest:"
field I would use "9025551212@200.200.200.200@5060" without the quotes.



PSTN User

PSTN-To-VoIP Selective Call Forward Settings

Cfwd Sel1 Caller: Turing A, 4444444

Cfwd Sel1 Dest: 9025551212@200.200.200.200@5060


 The rest of the SPA-3102 has to be configured properly (mine presumably
isn't as I am still having problems). Information on doing this is
abundant so I will not be through with it. Under "PSTN Line" a section
called "PSTN-To-VoIP Gateway Setup" should be configured.

 My very likely wrong config for that is;

PSTN-To-VoIP Gateway Setup
PSTN-To-VoIP Gateway Enable: yes    PSTN Caller Auth Method: none
PSTN Ring Thru Line 1: yes        PSTN PIN Max Retry:    3
PSTN CID For VoIP CID: no        PSTN CID Number Prefix:
PSTN Caller Default DP: 1        Off Hook While Calling VoIP: no

("Off Hook While Calling VoIP: no" is probably one of my problem causing
settings.)

In another section, delay values for forwarding should be set.
FXO Timer Values (sec)
VoIP Answer Delay: 0
PSTN Answer Delay: 4    

Most seem to get away with setting "PSTN Answer Delay" to 0, but most
need a little bit of time for the SPA3102 to read the Caller ID info and
4 seconds should do it for everyone according to my incomplete research.


 Here is what is happening.

 When Turing, A calls from (902) 444-4444 the call is forwarded to
voicemail. The phone rings allot first. In fact I can answer it and hear
the caller leave a voicemail. (I can hear the voicemail system voiced by
actor Alison Smith invite the caller to leave a message too.)

 I expect it will not require much tweaking to fix all that, I am not
overly concerned. The second issue does concern me.

 ALL other calls are picked up by the SPA 3102 and dropped after half a
ring.


 So in summary:

 I configured the device as needed by my VoIP provider and followed the
info going around on-line on configuring "PSTN-To-VoIP Gateway Setup" and
"FXO Timer Values" under the "PSTN Line" tab.


 Under "PSTN User" tab, and the "PSTN-To-VoIP Selective Call Forward
Settings" section I filled out "Cfwd Sel1 Caller:" with "Turing A,
4444444" (without the quotes) and "Cfwd Sel1 Dest:" with
"9025551212@200.200.200.200@5060" (without the quotes).


 Now the selected caller is sent to voicemail, but all other callers have
their calls hung-up on almost immediately.




Site Timeline