Kenwood RFU-6100

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View


Anyone have one?  I just got it, and am using it for my centre rear speaker.
No matter what I do, I can't seem to get much volume out of the speaker.
Plus the holes for the speaker wire are incredibly small; I'm gonna have to
re-wire it, using a thinner speaker wire.  And even though the red light
goes on, meaning it's not receiving any signal (like at night, or when it's
not in use) I sometimes get loud bangs coming out of the speaker.  I really
thought this unit would be a great investment -- it's actually why I just
made the leap into home theatre!  But it suffers from really low volume, and
I don't know what to do about it.  Or maybe that sixth discrete channel is
supposed to be lower in volume than the others.  I don't know.  I'm
confused, and mildly unhappy.
So does anyone have this unit (Kenwood RFU-6100)?  And how's it been working
for you?
vij




Re: Kenwood RFU-6100



vij wrote:
> Anyone have one?  I just got it, and am using it for my centre rear
speaker.
> No matter what I do, I can't seem to get much volume out of the
speaker.
> Plus the holes for the speaker wire are incredibly small; I'm gonna
have to
> re-wire it, using a thinner speaker wire.  And even though the red
light
> goes on, meaning it's not receiving any signal (like at night, or
when it's
> not in use) I sometimes get loud bangs coming out of the speaker.  I
really
> thought this unit would be a great investment -- it's actually why I
just
> made the leap into home theatre!  But it suffers from really low
volume, and
> I don't know what to do about it.  Or maybe that sixth discrete
channel is
> supposed to be lower in volume than the others.  I don't know.  I'm
> confused, and mildly unhappy.
> So does anyone have this unit (Kenwood RFU-6100)?  And how's it been
working
> for you?
> vij



Site Timeline