Smarthome Manager Plus

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
I've been using Smarthome Manager Plus and the 1132cu modules for years.  
About 6 months ago, I started getting the following message in a small  
window, after giving the download command:
   "SHUtils.dll missing - cannot download tree
   However, the instructions will be downloaded"
If I click on OK, it finishes and the download was successful. I looked  
in the c:\program files (x86)\smarthome\smarthome manager directory and  
there was a SHUtils1.dll file, but no SHUtils.dll file. So, I renamed  
the file to eliminate the 1 character and tried again. It worked. The  
next time I got the same message. This time both files were in the  
smarthome manager directory. BTW, this is installed under W7 and it used  
to always come up asking if I wanted smarthome to make changes to my  
computer. A yes, and all was fine. Now I don't get that; it just opens,  
but gives the error when trying to download. I know this program is not  
directly compatible with W7, however, using the install features of W7,  
which allow XP programs to run under W7, it said it was ok. And, as I  
said, has worked perfectly for years. Any ideas? Thanks.

Re: Smarthome Manager Plus
wrote:

Quoted text here. Click to load it

Mine continues to work well under Windows 7 x64 with all the latest
updates.  My dll has the 1 in it (ie, SHUtils1.dll).  It is dated
3/8/2004 1:51pm and its size is 451KB.  I never had any of the pop-ups
you mention, but I run as an administrator and am not using UAC.  A
while back, I figured out a lot of the 1132cu protocol and wrote my
own code to perform a lot of the functions.  However, I never figured
out how to download so I still use Smarthome Manager Plus for that. It
only gets used a few times per year, but it always seems to work.

Pat

Re: Smarthome Manager Plus
On 10/4/2014 4:13 PM, Pat wrote:
Quoted text here. Click to load it

Yup, mine is similar.  Only the time is different, 4:03PM. It always ran  
perfectly, as I said, until a few months ago. And it still runs ok, I  
just get the error/warning. I know there are few in this group still  
listening, but maybe someone will have some ideas. I'll keep playing  
with it.


Site Timeline