Connecting Modem to Console on 1700 series

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi Guys

I currently have a cisco 1700 that I'm trying to connect a modem
through to the console port.

The modem answers and says connected (see below from my management
station)

tip nops
connected
attd 901322359XXX
CONNECT 19200/ARQ/V34/LAPM/V42BIS

But moves no further from this prompt

Heres a copy of the configuration of the console port on my router:

line con 0
 exec-timeout 120 0
 password 7 xxxxxx
 login authentication console

Does anyone have any suggestions on succesful ways of configuring this?
If I connect the the AUX port it works fine.

Cheers
S


Re: Connecting Modem to Console on 1700 series
I was not aware that you could use the console port for this... my
understanding is that you must use the auxillary port.


Re: Connecting Modem to Console on 1700 series
Try knocking your modem down to 9600 baud and the other settings of
8N1.

J


Re: Connecting Modem to Console on 1700 series
wrote:

~ Hi Guys
~
~ I currently have a cisco 1700 that I'm trying to connect a modem
~ through to the console port.
~
~ The modem answers and says connected (see below from my management
~ station)
~
~ tip nops
~ connected
~ attd 901322359XXX
~ CONNECT 19200/ARQ/V34/LAPM/V42BIS
~
~ But moves no further from this prompt
~
~ Heres a copy of the configuration of the console port on my router:
~
~ line con 0
~  exec-timeout 120 0
~  password 7 xxxxxx
~  login authentication console
~
~ Does anyone have any suggestions on succesful ways of configuring this?
~ If I connect the the AUX port it works fine.
~
~ Cheers
~ S

The problem is likely that the answer modem has decided to set its DTE rate
to 19200 bps while the console port is set to 9600 bps.

Following is some hard earned advice on connecting modems to console ports.
Issue #3 is likely yours.

Cheers,

Aaron

---

When you configure a modem on the console, you need to be
aware of a few things:
 
1. The modem port does not do modem control.  This is a problem
for a couple of reasons:
 
1.1. If the call should hang up, the line will not drop.  So this is a
possible security threat - one user could log in then the modem
connection could drop, then someone else could dial in and be at
the console port without having had to authenticate.
 
Workarounds: use a modem with a built-in password; configure a
short exec-timeout to shrink the window of vulnerbility.
 
1.2. On a line with modem control enabled (modem inout or modem
dialin), the line will be up only if we see DSR - i.e. if DCD (modem
carrier) is high.  The modem will normally output result codes such as
"NO CARRIER", "RING", "CONNECT 9600" etc. only while its DCD is low
- therefore, modem result codes will not be seen by the line as user
input (unless you've configured 'no flush-at-activation'.)  However,
a line with no modem control (such as the console) sees ALL characters
received as user input.  This is probably what causes the problem
described below ... the modem has output result codes, and IOS is
seeing this as input to the Password: prompt.  Sometimes the modem's
AT parser can get into a "babble loop" with the console parser, where
each device is continuously outputting error messages in response to
the other's error messages.
 
Therefore, a modem on the console should always be configured for "dumb"
mode - do not display result codes and do not echo commands, do not
even parse AT commands.
 
2. Since you have to configure the console modem not to display
result codes, this means that modem autoconfigure can't work
(not sure if it could work in any case on a console line.)  Therefore
in order to configure the modem as desired, you must enter the
config via the AT interface and store it in modem NVRAM (&W typically.)
 
3.  Most modems unfortunately are unable to be explicitly configured
to a fixed DTE rate, and instead infer the DTE rate via autobauding
to characters received on the AT interface.  With such modems
(especially USRs), if you have only incoming not outgoing calls
(as would be the case with a console port) and if the DTE doesn't
periodically send AT commands (as would be the case without
modem autoconfigure), the modems are apt to forget what DTE rate
they're supposed to use, with the result being that you call in and
the modem decides that its DTE rate should be 38400 bps or some
dumb thing and so it can't talk with the console which is 9600 bps.
 
Workaround: configure the modem for a fixed DCE rate of 9600 bps
(with EC but no compression), and configure its DTE rate to follow
the DCE rate.
 
To summarize how to configure a modem on the console port then:
 
- force the modem to connect at a 9600 bps modulation (DCE link speed)
- either lock the DTE port speed at 9600, or else have the DTE speed
track the DCE speed (which is locked at 9600)
- enable error control
- no flow control
- DTR forced high
- autoanswer
- do not transmit result codes
- do not echo AT commands
- do not parse AT commands at all (dumb mode)
 
You can configure the modem by using DIP switches and/or AT commands.
To send the modem AT commands: connect to it via reverse telnet out an
aux port, or from a terminal program on a PC COM port. Issue the
AT command string ending with &W to write the configuration to NVRAM.
Note that you had better know what you're doing, since the AT interface
will be disabled after you issue the command.

---

Here are the steps to take specifically with a USR Courier Modem
to connect to a cisco router console port.
 
1.) Hook up modem to COM port on PC
2.) Set Hyperterminal settings to:
    9600 bps
    8 databits
    no parity
    1 stopbit
    no flow control
3.) connect to modem and issue the following AT string:
 
    at&f0s0=1&b0&n6&u6&m4&k0&w
    &F0 - no flow control factory template
    S0=1 - autoanswer after 1 ring
    &B0 - serial port rate follows DCE rate
    &N6 - 9600 bps max DCE rate
    &U6 - 9600 bps min DCE rate
    &M4 - EC with fallback to async
    &K0 - no data compression
    &W - write to  NVRAM
 
4.) set dip switches on modem to 1-3 up...4 down...5-10 up
5.) power-cycle the modem
6.) set configuration on console port of router to:
line con 0
exec-timeout x y --> where "x" is minutes and "y" is seconds
login
password xxxxx --> where "xxxxx" is your exec password
...and that's IT!!

Site Timeline