cisco 2811 and pppoe connection over ethernet

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi @ all, sorry for my bad english...


My ISP provides me an Internet connection with Ethernet cable with pppoe co
nnection mode. I have pfsense who runs a battery of servers behind this lin
e and everything works fine. The parameters login and password provided are
 correct. From pfsense I wanted to leap and run all through the cisco 2811  
I came into possession of a few days. After making some test configuration  
on the internal network, I decided to try my hand on his pppoe configuratio
n.  

I looked a bit on the internet and in the end I created my own configuratio
n.
Using 1667 out of 245752 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
!
dot11 syslog
ip source-route
!
ip cef
!
no ipv6 cef
multilink bundle-name authenticated
!
voice-card 0
!
archive
log config
  hidekeys
!
controller DSL 0/0/0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 10
!
interface FastEthernet0/1
ip address 172.16.0.254 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
!          
interface Vlan1
no ip address
!
interface Dialer1
ip address negotiated
ip mtu 1492
encapsulation ppp
dialer pool 10
ppp authentication pap callin
ppp pap sent-username xxx@yyy password 0 aabbccdd
ppp ipcp route default
!
ip forward-protocol nd
no ip http server
no ip http secure-server

I have this error:
*Apr 21 16:31:20.771:  Sending PADI: Interface = FastEthernet0/0
*Apr 21 16:31:20.799: PPPoE 0: I PADO  R:d4ca.6d3c.ed6e L:2893.fe7a.6d98 Fa
0/0
*Apr 21 16:31:22.819:  PPPOE: we've got our pado and the pado timer went of
f
*Apr 21 16:31:22.819: OUT PADR from PPPoE Session
*Apr 21 16:31:22.931: PPPoE 21677: I PADS  R:d4ca.6d3c.ed6e L:2893.fe7a.6d9
8 Fa0/0
*Apr 21 16:31:22.935: IN PADS from PPPoE Session
*Apr 21 16:31:22.939: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Apr 21 16:31:22.939: PPPoE: Virtual Access interface obtained.
*Apr 21 16:31:22.939: PPPoE : encap string prepared
*Apr 21 16:31:22.939: [0]PPPoE 21677: data path set to Virtual Acess
*Apr 21 16:31:22.947: %LINK-3-UPDOWN: Interface Virtual-Access2, changed st
ate to up
*Apr 21 16:31:22.947: Vi2 DDR: Dialer statechange to up
*Apr 21 16:31:23.439:  PPPoE : Shutting down client session
*Apr 21 16:31:23.439: [0]PPPoE 21677: O PADT  R:d4ca.6d3c.ed6e L:2893.fe7a.
6d98 Fa0/0
*Apr 21 16:31:23.439: %DIALER-6-UNBIND: Interface Vi2 unbound from profile  
Di1
*Apr 21 16:31:23.443: Vi2 DDR: disconnecting call
*Apr 21 16:31:23.443: PPPoE 21677: I PADT  R:d4ca.6d3c.ed6e L:2893.fe7a.6d9
8 Fa0/0
*Apr 21 16:31:23.443: %LINK-3-UPDOWN: Interface Virtual-Access2, changed st
ate to down

But i'm not albe to know why pppoe wan't go up&running :(

Thanks!!!

Re: cisco 2811 and pppoe connection over ethernet
devmustglamour@gmail.com wrote:
Quoted text here. Click to load it


I'd prefer to use CHAP rather than PAP if you can, it avoids sending
passwords in the clear.

Quoted text here. Click to load it

What debugs do you have enabled?  
It may help if you set  
#debug ppp negotiation
and post any relevant output.  

HTH,
--  
Nick B.

Site Timeline