Cisco 2600XM and external eth DSL modem

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hello
I would like to ask you how to configure a Cisco 2600XM (with 2 FE ports)
with an ADSL Line (RFC1483) and an external eth modem.

I have a 2651XM, on FE0/0 I have an external ETH modem, on FE0/1 I have the
LAN side 192.168.0.254/24

With an ADSL Wic I configured the cisco as the following:


interface FastEthernet0/0
description Interfaccia verso la backbone interna
ip address 172.16.0.241 255.255.254.0
no ip redirects
no ip proxy-arp
ip nat inside
ip virtual-reassembly
standby delay minimum 20 reload 20
standby version 2
standby 10 ip 172.16.0.1
standby 10 preempt delay minimum 20 reload 20 sync 10
standby 10 name R1A+R3P
standby 10 track 1
standby 10 track ATM0
hold-queue 100 out
!

interface ATM0/0
description ADSL
bandwidth 512
bandwidth receive 7000
no ip address
no ip redirects
no ip proxy-arp
atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0.1 point-to-point
ip address 89.186.xx.xx 255.255.255.252
ip access-group 100 in
no ip redirects
no ip proxy-arp
ip nat outside
ip virtual-reassembly
pvc 8/35
  encapsulation aal5snap
!
!


How should I configure an external adsl modem?

Thank you


Re: Cisco 2600XM and external eth DSL modem
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
enable password xxxxxxxx
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip name-server 216.xxx.xx.xxx (provided by telco)
ip name-server 216.xxx.xx.yyy (provided by telco)
!
!
!
!
Internet FastEthernet0/0
ip address 10.XX.XX.xx 255.0.0.0 (private network)
ip nat inside
duplex auto
speed auto
!
interface Serial 0/0
ip address 216.XXX.XX.XX 255.255.255.252 (provided by telco- customer ip)
ip nat outside
encapsulation ppp
no fair-queue
no dce-terminal-timing-enable
service-module t1 timeslots 1-24
service-module t1 remote-alarm-enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 216.xxx.xx.xx
!
ip http server
!
access-list 1 permit any
!
ip classless
ip route 0.0.0.0 0.0.0.0 216.XXX.xx.xx The 216 ip provided by telco-
telco ip)
!
ip http server
!
access-list 1 permit any
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password xxxxxxx
login
!
!
end


Re: Cisco 2600XM and external eth DSL modem
Quoted text here. Click to load it

When I was still using the ADSL lines, I had them configured
in "SIP Spoof" mode and connected to an ethernet interface (in
fact on a VLAN via a VLAN-capable switch) with standard config
for ethernet.
Advantage is that you don't have any NAT in the modem.

It seems like it is becoming more and more difficult to obtain
an ADSL modem that is just a modem, no builtin NAT router.
(although it is good that you don't use PPPoA, this makes everything
much worse but unfortunately is used by most local ISPs here)

What type of modem do you use?

Re: Cisco 2600XM and external eth DSL modem
Meanwhile, at the comp.dcom.sys.cisco Job Justification Hearings, Rob chose
the tried and tested strategy of:

Quoted text here. Click to load it

I've never heard of SIP spoof mode, but one thing you can do when you've
only got one routable IP but more than one device, is get a router that
supports (half-)bridge [there doesn't seem to be much standardisation here]
mode. The routable IP from the DSL gets assigned to a device on the LAN
somehow, and if you're lucky you can still manage your router via a
secondary private IP, and no-one's any the wiser until you tell them on
Usenet. It's what I'm doing here with a Thomson [now 'Technicolor'] ST780WL
and one public IP.

--
 <http://ale.cx/ (AIM:troffasky) (UnSoEsNpEaTm@ale.cx)
 19:51:50 up 13 days, 23:26,  1 user,  load average: 0.05, 0.08, 0.31
 "People believe any quote they read on the internet
  if it fits their preconceived notions." - Martin Luther King


Re: Cisco 2600XM and external eth DSL modem
Hello Rob.
I have abandoned this project because I will add an additional point of
failure, in the ext modem.

I could use standard eth adsl modem as the alcatel speedtouch 570 or similar




Quoted text here. Click to load it

When I was still using the ADSL lines, I had them configured
in "SIP Spoof" mode and connected to an ethernet interface (in
fact on a VLAN via a VLAN-capable switch) with standard config
for ethernet.
Advantage is that you don't have any NAT in the modem.

It seems like it is becoming more and more difficult to obtain
an ADSL modem that is just a modem, no builtin NAT router.
(although it is good that you don't use PPPoA, this makes everything
much worse but unfortunately is used by most local ISPs here)

What type of modem do you use?


Site Timeline