trying to make a gateway

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi
I have a 1605 , and since its got 2 ethernet ports I thought i would
like to use it in as a useful part of my network instaed of just a lab
situation.
I'm trying to configure my 1605 router as a gateway to the internet, but
not having much success.

192.168.1.0 is my primary network (172.16.1.16 secondary) and 202.0.62.4
goes to my cable modem (202.0.62.1)

Here's my running-config,
what have i missed ?,
  any help please ?

Router#sh conf
Using 683 out of 7506 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$K.Ac$8VHFnPMHi2TuvTcZF.NAC/
!
ip subnet-zero
ip name-server 202.0.62.1
!
!
!
interface Ethernet0
  ip address 172.16.1.16 255.255.0.0 secondary
  ip address 192.168.1.16 255.255.255.0
  ip directed-broadcast
  ip nat inside
!
interface Ethernet1
  ip address 202.0.62.4 255.255.0.0
  ip directed-broadcast
  ip nat outside
!
router rip
  network 172.16.0.0
  network 192.168.1.0
  network 202.0.64.0
!
ip classless
!
!
line con 0
  transport input none
line vty 0 4
  password cisco
  login
!
end

Re: trying to make a gateway

Quoted text here. Click to load it



I changed the typo network 202.0.64.0 to network 202.0.62.0
it still doesn't work

thanx


Re: trying to make a gateway
As far as I can see, your RIP table doesn't have a default route.....
If I'm correct you should try typing(in "configure terminal" mode):

ip route 0.0.0.0 Ethernet1




Quoted text here. Click to load it



Re: trying to make a gateway
Grant,

Your NAT will not work - you did not define major part of it - IP POOL. Here
is a link on how to configure simple NAT for Cisco IOS.

http://www.cisco.com/en/US/tech/tk648/tk361/technologies_configuration_example09186a0080093f2f.shtml

Also, do a little search on Cisco website for configuration examples, for
example, how to set access lists, do static translations, limit traffic,
etc.

Good luck,

Mike
CCNP, CCDP, CCSP, CCVP, MCSE W2K, MCSE+I, Security+, etc.
CCIE R&S (in progress), CCIE Voice (in progress)
------
Headset Adapters for Cisco IP Phones
www.ciscoheadsetadapter.com
www.headsetadapter.com


Quoted text here. Click to load it



Re: trying to make a gateway
Grant said the following on 4/05/2008 5:24 AM:
Quoted text here. Click to load it

<snip>

You haven't finished the NAT:
ip nat inside source list NAT_ACL interface Ethernet1 overload
!
ip access-list standard NAT_ACL
  permit 192.168.1.0 0.0.0.255
  permit 172.16.0.0 0.0.255.255

You also don't seem to have a default route:
ip route 0.0.0.0 0.0.0.0 202.0.62.1

Also, are you sure about that subnet mask on Ethernet 1? It seems
awfully large.

Can you ping 202.0.62.1?



Site Timeline