Trunking question

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi

I am doing a lab exercise in preparation for the BCMSN.

There is a 2950 access switch connected to two 3550 distribution
switches.

On the 2950, fa0/1 and fa0/2 are connected to 3550A and fa0/3 and fa0/4
are connected to 3550B.

At the moment, ports fa0/1 - 4 on the 2950 are in VLAN99.

The instructions are to -

i) Assign fa0/1 - 4 back to VLAN1.
ii) Turn on trunking on the ports connecting the 2950 and 3550's and
use 802.1Q trunking.

My response was;

i)

2950#conf t
2950(config)# interface range fa0/1 - 4
2950(config-if-range)# switchport access vlan 1
2950(config-if-range)# switchport mode trunk
2950(config-if-range)# switchport trunk encap dot1q

and then

3550A#conf t
3550A(config)# interface range fa0/1 - 2
3550A(config-if-range)# switchport mode trunk
3550A(config-if-range)# switchport trunk encap dot1q

and also

3550B#conf t
3550B(config)# interface range fa0/1 - 2
3550B(config-if-range)# switchport mode trunk
3550B(config-if-range)# switchport trunk encap dot1q

The lab, however, states that it should be;

2950#conf t
2950(config)# interface range fa0/1 - 4
2950(config-if-range)# switchport access vlan 1
2950(config-if-range)# switchport mode trunk
2950(config-if-range)# switchport nonegotiate

and then on both switches;

3550#conf t
3550(config)# interface range fa0/1 - 2
3550(config-if-range)# switchport mode trunk
3550(config-if-range)# switchport nonegotiate
3550(config-if-range)# switchport trunk encap dot1q

Which is correct, or is this just two ways of doing the same thing?

Thx


Re: Trunking question

Quoted text here. Click to load it


Different switches use different commands for creating vlans (i.e. vlan
database, vlan 2 name vlan2, switchport mode access, etc.)
Configuring Router subinterfaces is very important too.



Re: Trunking question
eager wrote:
Quoted text here. Click to load it
If I remember well "switchport trunk encap dot1q" does not exist on a 2950.


Site Timeline