Router to ISDN PC callback problem...

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!



I have problem with callback from router to my PC (ISDN). This is the
configuration of my Cisco router 1603. With this configuration I can connect
to router over ISDN link. Router screens my calling number but it doesn't
hang up and call me back. When I connect router should assign me private
address drom pool 10.0.0.2 - 10.0.0.5. So, my question is what else do I
have to put in my configuration for this thing to work. I want to initiate
call from my PC to router and than router should hang up and call me back.
Is this possible at all considering use of ISDN BRI connection? And if it is
what commands should I add to my config? Thanks.

!
enable password 7 011A0802541F03072F4D1E5C
!
username user password 7 104B0E0E02430101
ip subnet-zero
no ip domain-lookup
isdn switch-type basic-net3
!
!
!
interface Ethernet0
 description "connection toward private LAN"
 ip address 192.168.0.20 255.255.255.0
 no ip directed-broadcast
 ip nat outside
!

interface BRI0
 description "Connection to remote PC"
 no ip address
 no ip directed-broadcast
 ip nat inside
 encapsulation ppp
 dialer callback-secure
 dialer enable-timeout 2
 dialer-group 1
 isdn switch-type basic-net3
 no cdp enable
 ppp authentication chap
!
interface Dialer1
 description connected to Dial-inPCs(ISDN)
 ip address 10.0.0.1 255.255.255.0
 no ip directed-broadcast
 ip nat inside
 encapsulation ppp
 no ip split-horizon
 dialer remote-name user
 dialer enable-timeout 5
 dialer caller 2499xxx callback
 dialer pool 1
 dialer-group 1
 peer default ip address pool ADDR
 no cdp enable
 ppp authentication pap
!
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.0.0
 no auto-summary
!
ip local pool ADDR 10.0.0.2 10.0.0.5
ip nat inside source list 1 interface Ethernet0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.0.14
!
!
map-class dialer dial1
 dialer callback-server username
access-list 1 permit 10.0.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
 password 7 020F0A5D04120A29424F594C
 login
 transport input none
line vty 0 4
 password 7 08284248060D001F1C0A5C51
 login
 !
end




Site Timeline