Read over?...Dialup Config Tutorial

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!



Hello All,

Once again, I am writing a tutorial to help the simpler Cisco kids! This
tutorial is on Dialing an ISP using Cisco and AUX port.

Please could any of you scan your eyes over this very short tutorial and
give me your comments, tips, changes or additions ...

http://www.jlsnet.co.uk/index.php?tab=2&page=cc_dialup

This tutorial is not quite complete as I am having problems completing NAT,
please could anyone show me how NAT should be implemented in this dialup
case? I have tried putting "ip nat inside" on the LAN side and "ip nat
outside" on the Dialer and/or Async interfaces (not sure which should use?)
and "overloading" etc. I can access the internet from the router, but want
to provide it to the LAN, do I need to do it with a loopback address?

It is nearly there, but your help (as it has been in the past) would be
greatly appreciaed, and of course you will get credit where due!

cheers,

Jim




Cisco Configs - Using AUX port and analog modem to dialup ISP
Author: James Saunders
For some reason it seems that configuring a dialup connection from a Cisco
router to an ISP is a great mystery, the confusion is mainly due to the many
commands which are needed to setup a simple modem call and the various
different ways in which it can be achieved.
This tutorial attempts to describe, one of the simpler method of connecting
an analog modem to the AUX port on any Cisco router and configuring a Async
interface which will utilize the modem to dial any standard ISP like
Wannado, BT Openworld or AOL with a dialup account.
Equipment Setup
Following the same steps as found in the AUX Port Communications tutorial.
Connect the modem to the router's AUX port using a Rollover Cable.

When using cables which terminate in an RJ-45 from the AUX port, the 25-pin
modem adapter is required.
Find TTY number
You will need to find out which TTY/Async line the AUX port corresponds to,
this is done by issuing the "show line" command:

 Tty Typ     Tx/Rx    A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int

   0 CTY              -    -      -    -    -      0       0     0/0       -

  65 AUX              -    -      -    -    -      1       0     0/0       -

  66 VTY              -    -      -    -    -      0       0     0/0       -

  67 VTY              -    -      -    -    -      0       0     0/0       -

  68 VTY              -    -      -    -    -      0       0     0/0       -

  69 VTY              -    -      -    -    -      0       0     0/0       -

  70 VTY              -    -      -    -    -      0       0     0/0       -



You will notice in the "Typ" field (second column) there is one AUX port,
take note of the corresponding "Tty" number (first column) in this example
it is 65 on a 2611 router, but this may differ between router models.
The Configuration
On this occasion we will preview the whole configuration and then break it
down later in the tutorial describing what each section does:
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router
!
no aaa new-model
ip subnet-zero
!
ip name-server <<DNS Server IP Address>>
!
!
chat-script DIALOUT ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \\T" TIMEOUT 120
CONNECT \\c
modemcap entry MY_USR_MODEM:MSC=&F0X2L1M0S0=1
!
!
interface Ethernet0/0
ip address 192.158.1.254 255.255.255.0
no shutdown
!
interface Async65
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive
!
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer remote-name <<remote site name>>
dialer idle-timeout 300
dialer string <<phone number>>
dialer hold-queue 10
dialer-group 1
no peer default ip address
ppp authentication pap chap callin
ppp chap hostname <<username>>
ppp chap password 0 <<password>>
!
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
!
!
line con 0
password cisco
!
line aux 0
exec-timeout 0 0
script dialer DIALOUT
modem InOut
modem autoconfigure type MY_USR_MODEM
no exec
transport input all
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
password cisco
login
!
line vty 0
password cisco
login
line vty 1 4
password cisco
login
!
end


That is it! You may see other (over complicated) configs which attempt to do
the same thing, but this one works and is fairly self explanatory. Next we
will break it down to gain a greater insight as to what each command is
doing.
Name Server
!
ip name-server <<DNS Server IP Address>>
!


It is always a good idea to specify a name server, to enable the resolution
of domain names, if only for testing purposes. Use the configuration line
above, replacing the relevant part with the address of your ISP's DNS
server. You can have multiple "ip name-server" lines with alternate backup
DNS server addresses.
Chat and Modem Scripts
!
chat-script DIALOUT ABORT ERROR ABORT BUSY "" "ATZ" OK "ATDT \\T" TIMEOUT 120
CONNECT \\c
modemcap entry MY_USR_MODEM:MSC=&F0X2L1M0S0=1


The two configuration lines above are used to communicate with the modem
giving it instructions about what and how to dial. The "chat-script" is used
to issue the "AT" commands which get the modem off the hook and dialing, the
"chat-script" also specifies the timeout after which the modem will hangup
if an unsuccessful call is made.
The "modcap" line is used to tell the router further details about how to
communicate with the modem, these may be manufacturer specific to the type
of modem used (in this case relating to US Robotics modems). This line is
not essential and does not matter too much but should work with nearly all
modem manufacturers.
Async Interface
interface Async65
no ip address
encapsulation ppp
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive


Async is short for Asynchronous. Generally, commands entered in Async
interface mode enable you to configure protocol-specific parameters for
asynchronous interfaces. You need to configure an asynchronous interface in
order to support the PPP connection which will be needed when dialing an
ISP.
Earlier on in this tutorial we discovered the TTY line number that matched
the AUX port, in this example it was noted that the TTY number was 65. This
is of relevance because it also relates to the Async interface number, in
the configuration lines above you can see that "interface Async65" is used.
This means that the Async65 interface directly relates to the AUX port on
the front or back of the router, but this may differ between router models.
Dialer Interface
interface Dialer0
ip address negotiated
encapsulation ppp
dialer pool 1
dialer remote-name <<remote site name>>
dialer idle-timeout 300
dialer string <<phone number>>
dialer hold-queue 10
dialer-group 1
no peer default ip address
ppp authentication pap chap callin
ppp chap hostname <<username>>
ppp chap password 0 <<password>>
!


The next stage is to configure the interface which will actually dial the
ISP. The "Dialer" interface is a logical interface which can be used for
many purposes including ISDN and ADSL. In this example the Dialer interface
is used to communicate with the analog modem, dial the ISP's phone number,
authenticate PPP information and receive an IP address.
"ip address negotiated" - This command tells the router to gain its IP
address automatically from the ISP during the PPP negotiations. This method
of receiving an IP address is called IPCP (Internet Protocol Control
Protocol) A protocol used to establish and configure the IP protocol over
PPP. This is different to DHCP.
"encapsulation ppp" - Sets the encapsulation type of the interface to PPP,
this will enable the use of username and password authentication.
"dialer string" -The phone number to dial the ISP.
"dialer-group 1" - defines the "interesting traffic" list to use. This is
discussed later in this tutorial, it is used to only bring-up the phone line
when a certain type of traffic (e.g IP) is sent through it. The number 1
relates to the "dialer-list" seen further down in the configuration.
"ppp chap hostname" - this is the username of the dialup account.
"ppp chap password" - this is the password of the dialup account.
Default Route
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!

This command sets the default route (similar to default gateway) for ALL
traffic, in this example all traffic is sent to the Dialer0 interface,
setting the default route to the dialup connection.
Interesting Traffic
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101


Because phone calls (both analog and ISDN) are billed in time and not
traffic usage, it is not a good idea to have the interface constantly up
when not in use. Therefore an "interesting traffic" list is used to let the
Dialer know when it should bring the phone line up.
In this example ALL IP traffic to and from anywhere will activate the line,
but this list can be homed just as you would any access list to only allow
certain type of traffic to or from a certain place to activate the line.
The number of the dialer-list (in this example 1) relates to the
"dialer-group" command number seen in the Dialer0 interface above. The
number at the end of the command (in this example 101) relates to the
access-list which deny or permit the interesting traffic.
If there is no interesting traffic for a set period of time (dialer
idle-timeout) the Dialer interface will bring the line down, saving money!
Configure Line
line aux 0
exec-timeout 0 0
script dialer DIALOUT
modem InOut
modem autoconfigure type MY_USR_MODEM
no exec
transport input all
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
password cisco
login
!


The final step is to configure the AUX line which will communicate with the
modem. Commands entered in interface configuration mode relate to protocol
specific aspects, whereas commands entered in line configuration mode let
you configure the physical aspects (e.g. Speed, Flow Control, Stop Bits).
Notice the "MY_USR_MODEM" command which relates to the "moemcap"
configuration line discussed earlier.
The maximum speed for an AUX port is 115200, this is sufficient to
communicate with any modern modem. The "line aux 0" could also be referred
to as "line tty 65".
Debugs
debug ppp authentication

debug dialer
For More Information
JLSNet Cisco Configs - AUX Port Communication




Site Timeline