Re: Problem with OSPF route

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Jason wrote:

Quoted text here. Click to load it

Did you try to debug the adjacency process? What does "sh ip ospf neigh"
show?


Re: Problem with OSPF route

Quoted text here. Click to load it

Yeah the two routers are fully adjacent, here is the info:

On GROUCHO:

GROUCHO#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.3.1       1   FULL/  -        00:00:35    192.168.2.1     Serial0/0
GROUCHO#


On CHICO

CHICO#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.4.2       1   FULL/  -        00:00:38    192.168.2.2     Serial0
192.168.3.2       1   FULL/  -        00:00:34    192.168.3.2     Serial1
CHICO#

Re: Problem with OSPF route
Jason wrote:

Quoted text here. Click to load it

Post full config for GROUCHO and CHICO (at least "interface" and "router
ospf" config). Where does the 192.168.4.2 RID for GROUCHO come from?


Re: Problem with OSPF route
Jason wrote:

Quoted text here. Click to load it

Your configs are a bit messy :-)

First thing I'd do, is to remove eigrp and rip. I can't imagine why you
would want or need to run more than one routing protocol on the same links.
It's considered bad practice. Also remove all eigrp-related stuff, like
authentication, from interface configuration. EIGRP has a lower
administrative distance than OSPF, and most likely adversely interferes
with it.

Second, remove access-groups (in and out) from CHICO's serial0, since they
are not defined anywhere.

Third, you have asymmetric bandwidth/cost configurations for GROUCHO's s0/0
and CHICO's s0. On GROUCHO, you declare an OSPF cost of 300, while on CHICO
the cost is left at its default value (which is 10^8/bandwidth, or
10^8/10^6, or 100). Having different costs for a link at the opposite sides
is not recommended, since it can cause asymmetric routing. Either manually
adjust the costs, or the bandwidths, or remove both altogether and go with
the default values.

After all the above, reload the routers and see whether things get better.


Re: Problem with OSPF route

Quoted text here. Click to load it

Thanks for the advice, I'll try your suggestions. The configs are a bit
messy for two reasons:

1) I didn't erase the configs from the previos user
2) I've been experimenting with many different settings & trying different
configs to try to understand all the concepts

I've nearly finished both ICND1 & ICND2 books so most likely I'll erase
everything and start again when I've finished the second book & covered all
the topics.

Cheers, Jase.

Re: Problem with OSPF route

Quoted text here. Click to load it

It looks like removing RIP & EIGRP solved the problem, I've learned
something as I thought even if the administrative cost for a route was
lower it would at least be displayed in a 'show ip route' command so long
as it was UP & there were no other authentication / config problems. Thanks
for taking the time to look into the problem for me.

Jase

Re: Problem with OSPF route
Jason wrote:

Quoted text here. Click to load it

No, when the same route (destination/mask) is learned by multiple sources
(routing protocols), only the one with the lowest AD is entered into the
routing table.

Quoted text here. Click to load it

You're welcome.

Regards


Re: Problem with OSPF route
Jason wrote:
Quoted text here. Click to load it
You can also check for all ospf routes using 'show ip ospf database'.


Also.... Don't post your passwords....
jbeasley@jbeasley-desktop:~$ echo password 7 02000B5000031D7318 |
ios7decrypt.pl
password fokker24
jbeasley@jbeasley-desktop:~$ echo password 7 071C3543400C0B0A041718 |
ios7decrypt.pl
password stoneroses
jbeasley@jbeasley-desktop:~$ echo password 7 050D09042A495C5B4D |
ios7decrypt.pl
password fokker24
jbeasley@jbeasley-desktop:~$ echo password 7 1316031D0509162538213B |
ios7decrypt.pl
password stoneroses

Re: Problem with OSPF route



Quoted text here. Click to load it

Here are the 2 running configs, 192.168.4.2 is the ip address of another
ethernet port on GROUCHO which is 'DOWN' at the moment. I have been
using it to get my Internet connection working through my Cisco kit by
plugging my 3Com modem into it. OSPF just chose this IP address to use
as the ID for GROUCHO.


GROUCHO#show run
Building configuration...

Current configuration : 2362 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname GROUCHO
!
boot system tftp c2600-is-mz.121-27b.bin 192.168.1.50
boot system flash
aaa new-model
aaa authentication login default local
aaa authorization exec default local
enable secret 5 $1$FyMK$Zrr0VmdGOD3vNYR75Rjzf.
enable password 7 121A0C041104
!
username Jason password 7 02000B5000031D7318
ip subnet-zero
!
!
no ip domain-lookup
ip host HARPO 192.168.3.2
ip host CHICO 192.168.2.1
ip host SWITCH 192.168.1.2
ip dhcp excluded-address 192.168.1.1 192.168.1.9
ip dhcp excluded-address 192.168.1.25 192.168.1.255
ip dhcp excluded-address 192.168.1.17 255.255.255.0
ip dhcp excluded-address 192.168.1.12 255.255.255.0
ip dhcp excluded-address 192.168.1.11 255.255.255.0
!
ip dhcp pool Jason
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.100
   dns-server 4.2.2.2 4.2.2.3
   domain-name jason.co.uk
   lease 7
!
no ip bootp server
!
key chain jason
 key 1
  key-string 7 01100F175804
!
!
!
interface Ethernet0/0
 description LINK TO LAN
 ip address 192.168.7.1 255.255.255.0 secondary
 ip address 192.168.1.100 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 no ip mroute-cache
 full-duplex
 no cdp enable
!
interface Serial0/0
 bandwidth 100000
 ip address 192.168.2.2 255.255.255.252
 ip authentication mode eigrp 99 md5
 ip authentication key-chain eigrp 99 jason
 ip ospf cost 300
 no ip mroute-cache
!
interface Ethernet0/1
 description LINK TO INTERNET
 ip address 192.168.4.2 255.255.255.0
 ip nat inside
 no ip mroute-cache
 full-duplex
!
router eigrp 99
 network 192.168.1.0
 network 192.168.2.2 0.0.0.0
 auto-summary
!
router ospf 5
 log-adjacency-changes
 network 192.168.1.100 0.0.0.0 area 0
 network 192.168.2.2 0.0.0.0 area 0
 network 192.168.7.1 0.0.0.0 area 0
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.7.0
!
ip nat inside source list 102 interface Ethernet0/0 overload
ip nat inside source static udp 192.168.1.17 32459 interface Ethernet0/0
32459
ip nat inside source static tcp 192.168.1.17 32459 interface Ethernet0/0
32459
ip classless
no ip http server
!
!
line con 0
 exec-timeout 0 0
 password 7 071C3543400C0B0A041718
 logging synchronous
line aux 0
line vty 0 4
 access-class 1 in
 password 7 050D09042A495C5B4D
!
end



CHICO#show run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname CHICO
!
enable secret 5 $1$7F47$eFaUV7zrDHoKuM7oQFV0F/
!
username EAGLE1 password 7 1316031D0509162538213B
username Jason password 7 0115090F500E145D75
ip subnet-zero
no ip domain-lookup
ip host GROUCHO 192.168.2.2
ip host HARPO 192.168.3.2 255.255.255.0
isdn switch-type basic-ni
!
key chain jason
 key 1
  key-string 7 070C285F4D06
clock timezone BST 0
!
!
!
interface Serial0
 description LINK TO GROUCHO
 bandwidth 1000000
 ip address 192.168.2.1 255.255.255.252
 ip access-group jason2 in
 ip access-group jason out
 no ip directed-broadcast
 ip authentication mode eigrp 99 md5
 ip authentication key-chain eigrp 99 jason
 clockrate 64000
!
interface Serial1
 description LINK TO HARPO
 ip address 192.168.3.1 255.255.255.252
 no ip directed-broadcast
 ip authentication mode eigrp 99 md5
 ip authentication key-chain eigrp 99 jason
 clockrate 64000
!
interface TokenRing0
 no ip address
 no ip directed-broadcast
 shutdown
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 shutdown
 isdn switch-type basic-ni
!
router eigrp 99
 network 192.168.2.0
 network 192.168.3.0
!
router ospf 5
 network 192.168.2.1 0.0.0.0 area 0
 network 192.168.3.1 0.0.0.0 area 0
!
router rip
 version 2
 network 192.168.2.0
 network 192.168.3.0
!
ip classless
ip route 192.168.5.0 255.255.255.0 192.168.2.2
!
banner motd ^CThe old Eagle2^C
!
line con 0
 exec-timeout 0 0
 password 7 04481F0901245E411A1C16
 logging synchronous
 login local
 transport input none
line aux 0
line vty 0 4
 exec-timeout 0 0
 password 7 120D001B1C0E18
 login
!
end

Site Timeline