QoS questions

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi

I understand with "standard" QoS, you would map and match relevant
traffic, and then set an attribute such as IP Precedence.

For instance, supposing I wanted to set QoS for TFTP traffic, I would
enter the following in global config mode;

mls qos
access-list 101 permit udp any any eq tftp
class-map tftp
match access-group 101
policy-map precedence
class tftp
set ip precedence 5
interface range fa0/1 - 10
service-policy input precedence

Couple of questions;

a) On ACL 101, do I not need to enter 'permit ip any any' at the end
because of the implicit deny at the end, or because the ACL is just to
match a class of traffic is this unnecessary?
b) If I wanted to configure similar for VoIP, how would this be done?
Does VoIP have a port number (searched, but can't find), or can I type
along the lines access-list 101 permit tcp any any eq voip (I get an
error on my switch)?

Using auto-QoS, according to the Sybex book I could enter;

mls qos
interface fa0/1
auto qos voip cisco-phone

But will this actually give VoIP any priority over other traffic?

Thanks.


Re: QoS questions

Quoted text here. Click to load it

No, You do not need.
ACL "access-list 101 permit udp any any eq tftp" is ONLY for QoS purposes to
match traffic to QoS class.
All traffic except  ACL 101 do not match to class tftp and does not get
proper precedence but it is still allowed to go through interfaces fa0/1 -
10!


Quoted text here. Click to load it

Maybe this will help You a little:

Voice payload:

class-map voip
 match protocol rtp audio
 match ip rtp 16384 16383
 match ip precedence 5

Router#show auto qos
!
! First ACL matches Voice payload, second match Voice signaling
!
ip access-list extended AutoQoS-VoIP-RTCP
permit udp any any range 16384 32767

ip access-list extended AutoQoS-VoIP-Control
permit tcp any any eq 1720
permit tcp any any range 11000 11999
permit udp any any eq 2427
permit tcp any any eq 2428
permit tcp any any range 2000 2002
permit udp any any eq 1719
permit udp any any eq 5060


Regards,
Wlodek



Re: QoS questions

Everyman wrote:
Quoted text here. Click to load it

Thanks...so if I wanted to give voip traffic priority, would you
recommend the QoS commands you mention above, or the implementation of
a Voice VLAN?

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3750m/12225ey/3750mscg/swvoip.htm


Site Timeline