playing (badly) with frame-relay

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View


 Have two  routers back to back with a dce/dte cable; they communicate fine
with just RIP. I've started to play with WAN protocols, beginning with frame
relay,  based on the Cisco article "back to back frame relay hybrid
switching" ; as soon as I turn FR on the whole thing fails, in that I cant
ping across the routers.

" show frame-relay lmi" does , however, report communication between the
routers - I think I'm missing something here.....









show frame-relay lmi





LMI Statistics for interface Serial0 (Frame Relay DCE) LMI TYPE = CISCO

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Rcvd 123              Num Status msgs Sent 123

  Num Update Status Sent 0              Num St Enq. Timeouts 14

Router#









Router#debug frame-relay lmi

Frame Relay LMI debugging is on

Displaying all Frame Relay LMI data

Router#

Router#

00:31:07: Serial0(in): StEnq, myseq 138

00:31:07: RT IE 1, length 1, type 1

00:31:07: KA IE 3, length 2, yourseq 139, myseq 138

00:31:07: Serial0(out): Status, myseq 139, yourseen 139, DCE up

00:31:17: Serial0(in): StEnq, myseq 139

00:31:17: RT IE 1, length 1, type 1

00:31:17: KA IE 3, length 2, yourseq 140, myseq 139

00:31:17: Serial0(out): Status, myseq 140, yourseen 140, DCE up







Router 2524



version 11.3

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router

!

enable password ah

!

frame-relay switching

!

!

!

interface Ethernet0

 description test

 ip address 192.168.4.1 255.255.255.0

!

interface Serial0

 ip address 1.1.1.1 255.0.0.0

 encapsulation frame-relay

no ip mroute-cache

 no fair-queue

 clockrate 64000

 frame-relay map ip 1.1.1.2 101 broadcast

 frame-relay intf-type dce

!

interface Serial1

 no ip address

 shutdown

!

router rip

 network 1.0.0.0

 network 192.168.4.0

!

ip classless

!

logging history informational

!

line con 0

 exec-timeout 0 0

 --More--





--------------



1601

aaa new-model

aaa authentication login vyt_m enable

enable secret 5 $1$xFU8$DgDuZDb/PU.3alP4S1Gao1

enable password ah

!

!

interface Ethernet0

 ip address 192.168.1.4 255.255.255.0

 no ip route-cache

!

interface Serial0

 ip address 1.1.1.2 255.0.0.0

 encapsulation frame-relay

 no ip route-cache

 frame-relay map ip 1.1.1.1 101 broadcast

!

router rip

 network 1.0.0.0

 network 192.168.1.0







Re: playing (badly) with frame-relay
barret bonden wrote:
Quoted text here. Click to load it

Hi, perhaps you need to assign the DLCI to the interface.

e.g.
int s0/0
frame-relay interface-dlci 102

regards,
zenzippy

Re: playing (badly) with frame-relay
zenzippy wrote:
Quoted text here. Click to load it

also,

show frame-relay pvc is a good command :)

regards,
zenzippy

Re: playing (badly) with frame-relay
Turn off keepalives on both sides, assign the same DLCI on both ends.
Assign the clock rate on the DCE end. (no keepalive, frame-interface
dlci 101, clock rate 64000... etc). The keep alives are where the LMI
information is sent... it will keep your connection down.

Worked last time I tried it.


Quoted text here. Click to load it

Site Timeline