ip accounting precedence for non-transit traffic

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
In my home study lab, I'm finding that the 'ip accounting precedence
output' and 'show int e0/0 precedence' commands do not work as
expected when the same router is the one generated the traffic you're
hoping to capture.

What I was doing was using a policy-map to set the IP Precedence to 5
of generated ping packets and the 'show policy-map int e0/0' command
showed that these markings were being set. However, the 'show int e0/0
precedence' output showed this traffic as precedence 0 instead of 5.
So, although I can't find this written anywhere, it appears that if
the capturing and generating router are the same, the show output
won't have show the markings on the packets.  This is what I'm
gathering from my experiments.  Can anyone comment or corroborate
that?

thanks -

Re: ip accounting precedence for non-transit traffic
Verify first that the router really is marking the IP precedence of that
traffic to 5.  It is one thing to apply a policy-map to an interface when
the traffic is coming from outside of a router versus this situation where
the router is generating the traffic.  Also try an extended PING command
where you specify the source IP address of the PING to help match whatever
your policy map has, if applicable.

!
access-list 2001 remark *
access-list 2001 remark * Declaring ICMP (including PING) to 10.10.10.10 for
QoS
access-list 2001 remark *
access-list 2001 permit icmp any host 10.10.10.10
!
class-map match-any ICMPclass
 description * Classification of ICMP traffic to 10.10.10.10
 match access-group 2001
!
policy-map ICMPtagging
 description * Mark ICMP to 10.10.10.10 as IP Presedence 5
 class ICMPclass
  set ip precedence critical
!
interface Ethernet1
 service-policy input ICMPtagging
interface Ethernet0
 service-policy output ICMPtagging
!

-----

Scott Perry
Indianapolis, IN

-----

Quoted text here. Click to load it



Re: ip accounting precedence for non-transit traffic
Quoted text here. Click to load it

Thanks... those are good ideas...


Site Timeline