Individual static NAT on subnet 8, question?

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!





Hi Guys,

I have a specific need for a network setup and would
like you experts to comment on my work (Still learnig...)
for a 1841 router with ADSL WIC.

Requirements (Addresses are fictional):

Interface 0/0    Here we need a couple of global addresses, no NAT.
IP address 87.13.9.9 255.255.255.248 (/29)

Interface 0/1    Here we need a couple of local addresses with NAT to
2 of the /29 addresses above.
IP address  172.88.0.254 255.255.255.0

ATM interface 0/0/0  Here we have the same IP range as on Interface 0/0

The ATM is connected to ISP with a routed /29

It is expected that incomming packets to the 2 specific addresses in
the /29 get translated to 2 specific addresses on interface 0/1
while the 3 remaining addresses on ATM 0/0/0 get routed directly
to interface 0/0.

Proposed router CFG
!
interface FastEthernet0/0
 ip address 87.13.9.9 255.255.255.248
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.88.0.254 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 ...
 pvc ....
  encapsulation ....
  dialer pool-member 1
 !
!
interface Dialer1
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication chap callin
 ....
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip nat inside source static 172.88.0.1 87.13.9.12
ip nat inside source static 172.88.0.2 87.13.9.13


Would the above configuration do what I want?

Is it nescesary to do this too:

ip nat outside source static 87.13.9.12 172.88.0.1
ip nat outside source static 87.13.9.13 172.88.0.2

Thanks for your reply to what is probably a beginner question
in the Cisco relm of things.

Tony


Site Timeline