help with 827 config

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi there,

I have configured my Cisco 827 with the following configuration but cannot
get it to work, I have spent days and tried absolutely everything to get
this to work and trawled the net for examples but still no joy.

Could someone please take a look and see if they can see where I am going
wrong.  The config is a completely NO NAT config, the router has an external
ip address (same IP address on the WAN and the ethernet) and simply forwards
all traffic to my firewall (again on an external ip address).

Here is the config

version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname router-dslgw
!
logging rate-limit console 10 except errors
enable password password
!
mmi polling-interval 60
mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip finger
ip name-server 212.23.3.100
ip name-server 212.23.6.100
!
no ip dhcp-client network-discovery
!
!
!
interface Ethernet0
 ip address xxx.xxx.xxx.xxx 255.255.255.248
 ip rip v2-broadcast
 ip nat outside
 no ip route-cache
 no ip mroute-cache
 hold-queue 32 in
!
interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 0/16 ilmi
 !
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 bundle-enable
 dsl operating-mode auto
!
interface Dialer1
 ip unnumbered Ethernet0
 ip nat outside
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool 1
 ppp chap hostname xxxxxxxx@zen.co.uk
 ppp chap password xxxxxxx
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
!
ip nat pool netpool xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx prefix-length 12
ip nat inside source list 1 interface Dialer1 overload
access-list 1 permit any
access-list 101 permit ip any any
dialer-list 1 protocol ip permit
snmp-server manager
!
line con 0
 password temppass
 login
 transport input none
 stopbits 1
line vty 0 4
 password temppass
 login
!
scheduler max-task-time 5000
end



Re: help with 827 config
Hi Bunter,

You may wish to investigate the Cisco 827 Config Wizard:

http://www.ifm.net.nz/cookbooks/configwizard.html

Cisco 827 Basic Configuration:

http://www.ifm.net.nz/cookbooks/827_basic_nz.html

Cisco 827 Firewall Configuration:

http://www.ifm.net.nz/cookbooks/827_fw_nz.html

Cisco 827 Firewall PPTP Configuration:

http://www.ifm.net.nz/cookbooks/827_fw_pptp_nz.html

Cisco 827 Business Configuration:

http://www.ifm.net.nz/cookbooks/827_business_nz.html

Cisco 827 ADSL IPSec Configuration:

http://www.ifm.net.nz/cookbooks/827_ipsec_nz.html

Cisco 827 Firewall IPSec configuration:

http://www.ifm.net.nz/cookbooks/827_fw_ipsec_nz.html

Cisco 827 GUI Config:

http://www.ifm.net.nz/cookbooks/827h /

Hope this helps.

Brad Reese
BradReese.Com - Cisco Repair
http://www.bradreese.com/cisco-big-iron-repair.htm
1293 Hendersonville Road, Suite 17
Asheville, North Carolina  USA 28803
USA & Canada:  877-549-2680
International: 828-277-7272
Fax: 775-254-3558
AIM: R2MGrant
BradReese.Com - Cisco Power Supply Headquarters
http://www.bradreese.com/cisco-power-supply-inventory.htm


Site Timeline