dhcp not getting out

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi, I'm having problem adding DHCP service to my existing network.  My
laptop is getting priviate IP assigned when plugged into FastEthernet4/0/0,
and I can ping within network from my public subnet aa.bb.cc.0/20, but I
can't seem to get out to the Internet.  Possibly a routing issue?  Please
help.  Below is my setting:

!
ip dhcp pool dhcp1
   network 10.1.1.0 255.255.255.0
   dns-server aa.bb.cc.3 aa.bb.cc.4
   default-router 10.1.1.1
   domain-name abc.com
   lease infinite
!
interface FastEthernet4/0/0
 ip address 10.1.1.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 no ip mroute-cache
 load-interval 30
 full-duplex
 no cdp enable
!
interface FastEthernet5/0/0
 description --- Internet Gateway
 ip address xx.yy.zz.50 255.255.255.248
 ip access-group 111 in
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache flow
 no ip mroute-cache
 load-interval 30
 full-duplex
 no cdp enable
!
interface FastEthernet5/0/1
 description --- LAN for Switch
 ip address aa.bb.cc.1 255.255.240.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip route-cache policy
 ip route-cache flow
 no ip mroute-cache
 load-interval 30
 full-duplex
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 xx.yy.zz.49



Re: dhcp not getting out
Quoted text here. Click to load it

I don't see NAT in your configuration so are you doing it somewhere
else perhaps?  RFC1918 addresses are not routable on the Internet...


Re: dhcp not getting out
Quoted text here. Click to load it


Sorry, I forgot about NAT.  Below didn't work:
!
interface FastEthernet5/0/0
   ...
   ip nat outside
!
ip nat inside source list 1 interface FastEthernet5/0/0 overload
!
access-list 1 permit 10.1.1.0 0.0.0.255
!



Re: dhcp not getting out

Quoted text here. Click to load it
You're missing the other half of the NAT!
interface FastEthernet4/0/0
ip nat inside


Re: dhcp not getting out


Quoted text here. Click to load it

Still learning.  It worked, THANKS!!!



Site Timeline