CISCO VLANs and windows shared folders

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi,
i need to share folders between PCs that are on different VLANs.
How can it be done?
I'm using cisco catalyst 4503 routers and windows xp and 98, without windows
server...

Any help would be appreciated.
Thanks



Re: CISCO VLANs and windows shared folders

Quoted text here. Click to load it

use a router.....



Re: CISCO VLANs and windows shared folders
Quoted text here. Click to load it
other in a network. Since you are working in VLANs, you might actually
experience some problems.

My suggestion would be to connect those vlan using a router.

After you have done that, you just have to map the station with the
shared folder to your station. or you can always access it using
\\\\ipaddress


Re: CISCO VLANs and windows shared folders

Quoted text here. Click to load it


how can I do that,?
i'm still new to configuring routers...
can you give me some examples or commands?
thx..

Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders

Quoted text here. Click to load it

google + "router on a stick"

Quoted text here. Click to load it

One link from a results:
http://www.cisco.com/warp/public/473/50.shtml

--
KriS



Re: CISCO VLANs and windows shared folders

Quoted text here. Click to load it

give vlan 1 an ip address on the switch

#int vlan 1
#ip address 192.168.1.1 255.255.255.0

now on the router

create a sub interface for every VLAN including vlan 1 and create a network
address associated with each vlan

we used 192.168.1.1 as the ip address of vlan 1 so the network address for
this vlan is 192.168.1.0

so say you have 3 VLANs

vlan 1
vlan 2
vlan 3

now you only configure the ip address for vlan 1 not vlan 2 or vlan 3 (thats
on the switch)

on the router you create sub interfaces like so

#int fa0/0
#no shut
#    int fa0/0.1
#    encap dot1q 1
#    ip address 192.168.1.2 255.255.255.0
#    int fa0/0.2
#    encap dot1q
#    ip address 192.168.2.1 255.255.255.0
#    int fa0/0.3
#    encap dot1q
#    ip address 192.168.3.1 255.255.255.0
#    exit/end

now see the command "encap dot1q 1" well the 1 referrs to vlan 1, since the
network address of vlan 1 is 192.168.1.0 we need to keep the address of the
sub interface is the same network, the same goes for vlan 2 and vlan 3 only
no ip address needs to be configured for those on the switch.

now then

the default gateway of any machine on vlan 1 will be 192.168.1.2, the
gateway for any machine on vlan 2 will be 192.168.2.1 and for vlan 3 it will
be 192.168.3.1, ok

you need to configure a trunk between the switch and the router you do this
on the switch using the following commands

#int fa0/1
#switchport mode trunk

thats a rough guide uing example ip addresses hope it kind of helps






Re: CISCO VLANs and windows shared folders
thank you!!
that is what i need.

most of the things I have already configured but i missed the part with
subinterfaces...


Quoted text here. Click to load it
network
(thats
Quoted text here. Click to load it
the
the
only
will
this



Re: CISCO VLANs and windows shared folders
ok, now i have almost everything configured

your example and link from Kris helped a lot, thx both
( http://www.cisco.com/warp/public/473/50.shtml )

but I cann't  create subinterface on a router?
i only get : invalid input detected...

4503NB(config)#int g1/19.1

% Invalid input detected at '^' marker.

am I using incorrect syntax or what? (CISCO 4503 router)


Quoted text here. Click to load it
the
the
only
will
this



Re: CISCO VLANs and windows shared folders
Re: CISCO VLANs and windows shared folders
4503 is a layer 3 device but not router?
so it doesn't support subinterfaces, and I'm at the beginning again? (there
is nothing about subinterfaces in configuration guide)...

I mean, inter VLAN traffic works fine if I use FTP, HTTP...
but what I need now is shared folders and network drive mapping between
different VLANs.... is that possible with 4503 or not?

somebody said that he can do such thing with windows server, but I don't
have it...





Quoted text here. Click to load it
http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
Just read the document.
ip routing
interface Vlan2
  ip address 10.1.1.1 255.255.255.0
interface Vlan3
 ip address 10.2.2.2 255.255.255.0

And it works.

Quoted text here. Click to load it
http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
well, it's not working, everything is configured as it should be....


Quoted text here. Click to load it
http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
Show your config.

conf t
interface range fastethernet 2/1 -48
switchport mode access
switchport access vlan 2

interface range fastethernet 3/1 -48
switchport mode access
switchport access vlan 3

ip routing

vlan 2
vlan 3

interface Vlan2
 ip address 10.1.1.1 255.255.255.0
interface Vlan3
ip address 10.2.2.2 255.255.255.0


Quoted text here. Click to load it
http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
Verification



Building configuration...



Current configuration : 4805 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service compress-config

!

hostname 4503NB

!

enable secret 5 $1$N/M2$V6YQfFyPhm3WcBox1qbla0

enable password ep4503nb

!

ip subnet-zero

ip host NEU 10.0.0.9

ip host AMB 10.0.0.6

ip host OPE 10.0.0.4

ip host SBC 10.0.0.2

ip host CEN 10.0.0.1

ip host UPR 10.0.0.3

ip host KAR 10.0.0.7

ip host RTG 10.0.0.8

ip host PAT 10.0.0.5

ip host ASA 192.168.10.1

ip dhcp excluded-address 172.16.4.1 172.16.4.10

ip dhcp excluded-address 172.16.4.200 172.16.4.254

!

ip dhcp pool DOKTORI

   network 172.16.4.0 255.255.255.0

   default-router 172.16.1.253

   option 150 ip 172.16.4.253

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

power redundancy-mode redundant

!

!

!

vlan internal allocation policy ascending

!

interface GigabitEthernet1/1

 switchport access vlan 2

!

interface GigabitEthernet1/2

 switchport access vlan 9

!

interface GigabitEthernet1/3

!

interface GigabitEthernet1/4

!

interface GigabitEthernet1/5

!

interface GigabitEthernet1/6

!

interface GigabitEthernet1/7

!

interface GigabitEthernet1/8

!

interface GigabitEthernet1/9

!

interface GigabitEthernet1/10

!

interface GigabitEthernet1/11

!

interface GigabitEthernet1/12

!

interface GigabitEthernet1/13

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet1/14

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet1/15

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet1/16

!

interface GigabitEthernet1/17

!

interface GigabitEthernet1/18

!

interface GigabitEthernet1/19

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface GigabitEthernet1/20

 switchport trunk encapsulation dot1q

 switchport mode trunk

!

interface FastEthernet2/1

 switchport access vlan 15

 spanning-tree portfast

!

interface FastEthernet2/2

 switchport access vlan 172

 spanning-tree portfast

!

interface FastEthernet2/3

 switchport access vlan 172

 spanning-tree portfast

!

interface FastEthernet2/4

 switchport access vlan 172

 spanning-tree portfast

!

interface FastEthernet2/5

 switchport access vlan 172

 spanning-tree portfast

!

interface FastEthernet2/6

 switchport access vlan 172

 spanning-tree portfast

!

interface FastEthernet2/7

 switchport access vlan 172

 spanning-tree portfast

!

interface FastEther

 switchport access vlan 172

 spanning-tree portfast

!

interface FastEthernet2/9

 switchport access vlan 4

 spanning-tree portfast

!

interface FastEthernet2/10

 switchport access vlan 4

 spanning-tree portfast

!

interface FastEthernet2/11

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/12

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/13

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/14

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/15

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/16

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/17

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/18

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/19

 switchport access vlan 3

 spanning-tree portfast

!

interface FastEthernet2/20

 spanning-tree portfast

!

interface FastEthernet2/21

 spanning-tree portfast

!

interface FastEthernet2

 switchport access vlan 4

 spanning-tree portfast

!

interface FastEthernet2/23

 spanning-tree portfast

!

interface FastEthernet2/24

 switchport access vlan 7

 spanning-tree portfast

!

interface Vlan1

 ip address 10.0.0.1 255.255.255.0

!

interface Vlan3

 ip address 172.16.3.253 255.255.255.0

!

interface Vlan4

 ip address 172.16.4.253 255.255.255.0

!

interface Vlan5

 ip address 172.16.5.253 255.255.255.0

!

interface Vlan7

 ip address 192.168.0.253 255.255.255.0

!

interface Vlan8

 ip address 172.16.8.253 255.255.255.0

!

interface Vlan9

 ip address 192.168.10.253 255.255.255.0

!

interface Vlan10

 ip address 172.16.10.253 255.255.255.0

!

interface Vlan15

 ip address 192.168.90.253 255.255.255.0

!

interface Vlan172

 ip address 172.16.1.253 255.255.255.0

!

router rip

 network 10.0.0.0

 network 172.16.0.0

 network 192.168.10.0

 network 192.168.90.0

!

ip route 0.0.0.0 0.0.0.0 192.168.10.1

no ip http server

!

!

!

access-list 103 permit tcp 172.16.10.0 0.0.0.255 172.16.1.0 0.0.0.255

access-list 103 permit icmp 172.16.10.0 0.0.0.255 172.16.1.0 0.0.0.255

access-list 104 permit tcp 172.16.1.0 0.0.0.255 172.16.10.0 0.0.0.255
establishe

d

access-list 104 permit icmp 172.16.1.0 0.0.0.255 172.16.10.0 0.0.0.255

!

!

!

line con 0

 session-timeout 30

 exec-timeout 0 0

 stopbits 1

line vty 0 4

 password

 login

!

end

Quoted text here. Click to load it
between
http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
I dont see "ip routing" in your config. And also missing vlans.
Send your "show vlan" and "show ip route".

And put in your config:
vlan 172
vlan 15
vlan 10
vlan 9
vlan 8
vlan 7
vlan 5
vlan 4
vlan 3
vlan 1


Quoted text here. Click to load it
http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
I think you've all missed the point.  He doesn't have a Cisco problem, he has a
Microsoft problem.  As you'll note from a much earlier post, he already has
routed inter-vlan connectivity--it works for http and ftp.  While his config
could probably stand a bit of cleaning-up, it does work.  The real problem is
making windows boxes that reside in different broadcast domains recognize each
other peer-to-peer without a server.  Needs to be asked in a Microsoft group
instead.

Make wrote:
Quoted text here. Click to load it


Re: CISCO VLANs and windows shared folders
the problem is that some think that it should work as Make said,
and other think like you Mike.... and I just don't know :)




Quoted text here. Click to load it
has a
has
config
is
each
group
ion_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
VLAN Name                             Status    Ports

---- -------------------------------- --------- ----------------------------
---

1    default                          active    Gi1/3, Gi1/4, Gi1/5, Gi1/6

                                                Gi1/7, Gi1/8, Gi1/9, Gi1/10

                                                Gi1/11, Gi1/12, Gi1/16,
Gi1/17

                                                Gi1/18, Fa2/20, Fa2/21,
Fa2/23

2    dsl                              active    Gi1/1

3    LJEKARNA                         active    Fa2/11, Fa2/12, Fa2/13,
Fa2/14

                                                Fa2/15, Fa2/16, Fa2/17,
Fa2/18

                                                Fa2/19

4    INTERNET                         active    Fa2/9, Fa2/10, Fa2/22

5    UPRAVA                           active

7    TC                               active    Fa2/24

8    DIJAGNOSTIKA                     active

9    asa                              active    Gi1/2

10   IT                               active

15   asaman                           active    Fa2/1

172  ADMNISTRATORI                    active    Fa2/2, Fa2/3, Fa2/4, Fa2/5

                                                Fa2/6, Fa2/7, Fa2/8

1002 fddi-default                     act/unsup

1003 trcrf-default                    act/unsup

1004 fddinet-default                  act/unsup







Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static
route

       o - ODR, P - periodic downloaded static route



Gateway of last resort is 192.168.10.1 to network 0.0.0.0



C    192.168.90.0/24 is directly connected, Vlan15

C    192.168.10.0/24 is directly connected, Vlan9

     172.16.0.0/24 is subnetted, 6 subnets

C       172.16.8.0 is directly connected, Vlan8

C       172.16.10.0 is directly connected, Vlan10

C       172.16.4.0 is directly connected, Vlan4

C       172.16.5.0 is directly connected, Vlan5

C       172.16.1.0 is directly connected, Vlan172

C       172.16.3.0 is directly connected, Vlan3

     10.0.0.0/24 is subnetted, 1 subnets

C       10.0.0.0 is directly connected, Vlan1

C    192.168.0.0/24 is directly connected, Vlan7

S*   0.0.0.0/0 [1/0] via 192.168.10.1







Quoted text here. Click to load it
again?
Quoted text here. Click to load it
http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
Thank you guys for the help!!


it's working now...



Quoted text here. Click to load it
--
Quoted text here. Click to load it
Gi1/10
Quoted text here. Click to load it
level-2
Quoted text here. Click to load it
be....
I
http://www.cisco.com/en/US/products/hw/switches/ps4324/products_configuration_guide_chapter09186a00803b6e80.html
Quoted text here. Click to load it



Re: CISCO VLANs and windows shared folders
And the problem was?

Quoted text here. Click to load it



Site Timeline