cisco 831 and my miserable upload speeds

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
i replaced my BEFSR41 with an Cisco 831.  my upload speeds since then
have dropped significantly.  i was able to get close to the 384kbps with
the linksys router, but now i get a lousy range of 50-112kbps.

i'm pretty sure this has something to do with my QoS policies, but i'm
not sure where the problem lies.

my understanding was these QoS policies set a fixed bandwidth in the
event specified traffic needed bandwidth.  if there is no need for the
bandwidth then any traffic can use the bandwidth.  at the moment it
seems that the block of bandwidth is isolated and no other traffic can
use it.

here's my current config:

-----------------------
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname pluto
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxx
!
aaa new-model
!
!
!
aaa session-id common
!
resource policy
!
ip subnet-zero
!
!
ip nbar port-map sip udp 5060 5061 5062 5063 5064 5065
no ip dhcp use vrf connected
!
!
ip cef
ip domain name sol.home
no ip ips deny-action ips-interface
ip ssh time-out 60
ip ssh authentication-retries 2
!
no ftp-server write-enable
!
!
class-map match-any warcraft
description warcraft
 match access-group name warcraft
class-map match-any VoIP
 match protocol rtp audio
class-map match-any normal_traffic
 match protocol http
 match protocol secure-http
 match protocol dns
 match protocol smtp
 match protocol pop3
 match protocol ntp
 match protocol icmp
class-map match-any sip
 match protocol sip
!
!
policy-map MyQoSPolicy
 class VoIP
  set dscp ef
  priority 90
 class warcraft
  priority 10
 class normal_traffic
  priority 20
 class sip
  priority 15
  set dscp ef
 class class-default
  fair-queue
!
!
no crypto isakmp ccm
!
!
!
interface Ethernet0
 ip address 10.10.100.1 255.255.255.248
 ip nat inside
 no ip virtual-reassembly
!
interface Ethernet1
 bandwidth 384
 ip address dhcp
 ip nbar protocol-discovery
 ip nat outside
 no ip virtual-reassembly
 duplex auto
 service-policy output MyQoSPolicy
!
interface Ethernet2
 no ip address
 shutdown
!
interface FastEthernet1
 duplex auto
 speed auto
!
interface FastEthernet2
 duplex auto
 speed auto
!
interface FastEthernet3
 duplex auto
 speed auto
!
interface FastEthernet4
 duplex auto
 speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 dhcp
!
ip http server
no ip http secure-server
!
ip nat inside source list OUTBOUND_ADDRESSES interface Ethernet1
overload
ip nat inside source static tcp 10.10.100.5 6112 interface Ethernet1
6112
ip nat inside source static udp 10.10.100.5 6112 interface Ethernet1
6112
!
!
ip access-list standard OUTBOUND_ADDRESSES
 permit 10.10.100.4
 permit 10.10.100.5
 permit 10.10.100.2
 permit 10.10.100.3
!
ip access-list extended warcraft
 permit udp any any eq 6112
 permit tcp any any eq 6112
!
!
control-plane
!
banner motd ^CC
You are connected to $(hostname) on a private network.
Use of this system may be logged or monitored without further notice.
 Unauthorized access is prohibited.
Violators will be prosecuted.
^C
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 transport input ssh
!
scheduler max-task-time 5000
end

Re: cisco 831 and my miserable upload speeds
Why don't you remove your policies completely and see what happens to
your speed?

xyyz wrote:
Quoted text here. Click to load it

Site Timeline