Bah...more problems..

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Ok fellas, I almost made it to the part where I could copy my ios from
one router to the other.  (I could have, but wanted to test out my
setup, and obviously if I'm here it failed.)  Ok, here is my setup....



R1(s0)--------(s0)R2(s1)-----------(s0)R3(e0)------
(f0/1)SW(f0/2)--------PC

I can ping from my PC to my switch and from my switch to R3...but I
can't ping from my PC to R3...I'm lost......Let me know if yall need
me to send my config's...

Thanks for the help!


Re: Bah...more problems..

Quoted text here. Click to load it

Is the switchport the router's connected to in the same vlan as the pc?  Is
that link up?



Re: Bah...more problems..

Quoted text here. Click to load it

Oh and , yes, configs would help heaps.



Re: Bah...more problems..
Quoted text here. Click to load it

Ok, I will send the configs in just a second.  And no I do not have
switchport access vlan or switchport mode access in the configs
because I thought if you did not define that, it puts all ports on
VLAN1, which is your switch VLAN.  Am I wrong in thinking this?  Or do
I have to put the "gateway port" to the rest of the network on it's
own VLAN and assign individual ports to it?  I'm about to send the
config in the next post.

Thanks!


Re: Bah...more problems..
Quoted text here. Click to load it


All I want to do right now is ping across my network, which I typed a
generic diagram of in the original post..Here is my switch config:

sh run
Building configuration...

Current configuration:
!
version 11.2
no service pad
no service udp-small-servers
no service tcp-small-servers
!
hostname 2924Catalyst-Training
!
enable secret 5 $1$ueA2$ecZZM3cl1Jm39ZMTAu3Lk/
!
!
!
clock timezone EST 0
!
interface VLAN1
 ip address 192.168.21.1 255.255.255.0
 no ip route-cache
!
interface VLAN2
 ip address 192.168.18.2 255.255.255.0
 no ip route-cache
 shutdown
!
interface FastEthernet0/1
 switchport access vlan 2
!
interface FastEthernet0/2
 switchport access vlan 2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
 spanning-tree portfast
!
interface FastEthernet0/6
 spanning-tree portfast
!
interface FastEthernet0/7
 spanning-tree portfast
!
interface FastEthernet0/8
 spanning-tree portfast
!
interface FastEthernet0/9
 spanning-tree portfast
!
interface FastEthernet0/10
 spanning-tree portfast
!
interface FastEthernet0/11
 spanning-tree portfast
!
interface FastEthernet0/12
 spanning-tree portfast
!
interface FastEthernet0/13
 spanning-tree portfast
!
interface FastEthernet0/14
 spanning-tree portfast
!
interface FastEthernet0/15
 spanning-tree portfast
!
interface FastEthernet0/16
 spanning-tree portfast
!
interface FastEthernet0/17
!
interface FastEthernet0/18
 spanning-tree portfast
!
interface FastEthernet0/19
 spanning-tree portfast
!
interface FastEthernet0/20
 spanning-tree portfast
!
interface FastEthernet0/21
 spanning-tree portfast
!
interface FastEthernet0/22
 spanning-tree portfast
!
interface FastEthernet0/23
 spanning-tree portfast
!
interface FastEthernet0/24
!
interface FastEthernet2/1
!
interface FastEthernet2/2
!
interface FastEthernet2/3
!
interface FastEthernet2/4
!
ip default-gateway 192.168.18.1
snmp-server community private RW
snmp-server community public RO
snmp-server chassis-id 0x10
!
line con 0
 password cisco
 login
 stopbits 1
line vty 0 4
 login
line vty 5 9
 login
!
end

2924Catalyst-Training#



Re: Bah...more problems..

Quoted text here. Click to load it

From your other post ... "And no I do not have switchport access vlan or
switchport mode access in the configs because I thought if you did not
define that, it puts all ports on VLAN1,"

So why do fa0/1 and fa0/2 have :"switchport access vlan 2" configured?


And vlan 2 interface is shutdown?  You said you could ping the router from
the switch but the interface connected to the router is in vlan 2 and vlan 2
interface is shutdown.

The switches vlan interface being shutdown won't affect pinging the router
from the pc though.  As long as R3's e0 interface is configured with a
192.168.18.0/24 address.



Re: Bah...more problems..
Quoted text here. Click to load it

Yeah I added that in after I read the posts about vlans and I still
couldn't ping across the switch.  I even plugged my laptop directly
into the e0 on R3 and I couldn't ping the e0 from DOS on the laptop.
So I'm really confused now... I can't ping through the switch and I
can't ping the router when my laptop is directly plugged in so I guess
it's a problem with my laptop or my router recognizing my laptop.


Re: Bah...more problems..
Quoted text here. Click to load it

Ok, got it working, seems I have to have all the networks the
same..like so:

Router(e0): 192.168.18.1
Switch(VLAN1): 192.168.18.2
My Laptop: 192.168.18.3

go figure..thanks for pointing me in the right direction...it wont be
the last time im sure..



Site Timeline