Anybody know why this vlan config wont work

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View


Quoted text here. Click to load it
this format, some or all of this message may not be legible.

--B_3198541877_1013967
Content-type: text/plain;
    charset="US-ASCII"
Content-transfer-encoding: 7bit

I have a router using ospf and a switch connected to the router. The switch
and the router are connected using the fa0/1 on the router and the fa0/1 on
the switch

Here are the running configs..... Just wondering why I cant ping 172.16.1.2
from the router, and 172.16.1.1 from the switch

SWITCH:
!
hostname Switch
!
ip subnet-zero
!
interface FastEthernet0/1
 keepalive 10
 switchport mode trunk
!
interface FastEthernet0/2
!
!        
interface VLAN1
 ip address 172.16.1.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 172.16.1.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 login
line vty 5 15
 login
!
end


VLAN1 is up, line protocol is up
  Hardware is CPU Interface, address is 0008.a494.42c0 (bia 0008.a494.42c0)
  Internet address is 172.16.1.2/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set


ROUTER

Router#sh run
Building configuration...

Current configuration : 1124 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
memory-size iomem 25
ip subnet-zero
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1
 ip address 192.169.1.1 255.255.255.0
!
interface Serial0/0
 ip address 172.16.100.1 255.255.255.252
 clockrate 56000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 1
 ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/1.10
 encapsulation dot1Q 10
!        
interface FastEthernet0/1.20
 encapsulation dot1Q 20

router ospf 1
 log-adjacency-changes
 network 172.16.1.0 0.0.0.255 area 0
 network 172.16.100.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 default-information originate
!
ip classless
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

--B_3198541877_1013967
Content-type: text/html;
    charset="US-ASCII"
Content-transfer-encoding

<HTML>
<HEAD>
<TITLE>Anybody know why this vlan config wont work</TITLE>
</HEAD>
<BODY>
<FONT FACE=3D"Verdana, Helvetica, Arial"><SPAN STYLE=3D'font-size:12.0px'>I hav=
e a router using ospf and a switch connected to the router. The switch and t=
he router are connected using the fa0/1 on the router and the fa0/1 on the s=
witch<BR>
<BR>
Here are the running configs..... Just wondering why I cant ping 172.16.1.2=
 from the router, and 172.16.1.1 from the switch<BR>
<BR>
</SPAN><FONT COLOR=3D"#FF0000"><FONT SIZE=3D"6"><SPAN
STYLE=3D'font-size:20.0px'>SWITCH:<BR>

</SPAN></FONT></FONT><SPAN STYLE=3D'font-size:12.0px'>!<BR>
hostname Switch<BR>
!<BR>
ip subnet-zero<BR>
!<BR>
interface FastEthernet0/1<BR>
&nbsp;keepalive 10<BR>
&nbsp;switchport mode trunk<BR>
!<BR>
interface FastEthernet0/2<BR>
!<BR>
! &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<BR>
interface VLAN1<BR>
&nbsp;ip address 172.16.1.2 255.255.255.0<BR>
&nbsp;no ip directed-broadcast<BR>
&nbsp;no ip route-cache<BR>
!<BR>
ip default-gateway 172.16.1.1<BR>
!<BR>
line con 0<BR>
&nbsp;transport input none<BR>
&nbsp;stopbits 1<BR>
line vty 0 4<BR>
&nbsp;login<BR>
line vty 5 15<BR>
&nbsp;login<BR>
!<BR>
end<BR>
<BR>
<BR>
VLAN1 is up, line protocol is up <BR>
&nbsp;&nbsp;Hardware is CPU Interface, address is 0008.a494.42c0 (bia 0008.=
a494.42c0)<BR>
&nbsp;&nbsp;Internet address is 172.16.1.2/24<BR>
&nbsp;&nbsp;MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec, <BR>
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;reliability 255/255, txload 1/255, rxload 1/2=
55<BR>
&nbsp;&nbsp;Encapsulation ARPA, loopback not set<BR>
<BR>
<FONT COLOR=3D"#FF0000"><BR>
</FONT></SPAN><FONT COLOR=3D"#FF0000"><FONT SIZE=3D"6"><SPAN
STYLE=3D'font-size:20.0px'>ROUTER<BR>

</SPAN></FONT></FONT><SPAN STYLE=3D'font-size:12.0px'><BR>
Router#sh run<BR>
Building configuration...<BR>
<BR>
Current configuration : 1124 bytes<BR>
!<BR>
version 12.1<BR>
service timestamps debug uptime<BR>
service timestamps log uptime<BR>
no service password-encryption<BR>
!<BR>
hostname Router<BR>
!<BR>
memory-size iomem 25<BR>
ip subnet-zero<BR>
!<BR>
interface FastEthernet0/0<BR>
&nbsp;no ip address<BR>
&nbsp;shutdown <BR>
&nbsp;duplex auto<BR>
&nbsp;speed auto<BR>
!<BR>
interface FastEthernet0/0.1<BR>
&nbsp;encapsulation dot1Q 1<BR>
&nbsp;ip address 192.169.1.1 255.255.255.0<BR>
!<BR>
interface Serial0/0<BR>
&nbsp;ip address 172.16.100.1 255.255.255.252<BR>
&nbsp;clockrate 56000<BR>
!<BR>
interface FastEthernet0/1<BR>
&nbsp;no ip address<BR>
&nbsp;duplex auto<BR>
&nbsp;speed auto<BR>
!<BR>
interface FastEthernet0/1.1<BR>
&nbsp;encapsulation dot1Q 1<BR>
&nbsp;ip address 172.16.1.1 255.255.255.0<BR>
!<BR>
interface FastEthernet0/1.10<BR>
&nbsp;encapsulation dot1Q 10<BR>
! &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;<BR>
interface FastEthernet0/1.20<BR>
&nbsp;encapsulation dot1Q 20<BR>
<BR>
router ospf 1<BR>
&nbsp;log-adjacency-changes<BR>
&nbsp;network 172.16.1.0 0.0.0.255 area 0<BR>
&nbsp;network 172.16.100.0 0.0.0.255 area 0<BR>
&nbsp;network 172.16.0.0 0.0.255.255 area 0<BR>
&nbsp;default-information originate<BR>
!<BR>
ip classless<BR>
no ip http server<BR>
!<BR>
!<BR>
line con 0<BR>
line aux 0<BR>
line vty 0 4<BR>
!<BR>
no scheduler allocate<BR>
end</SPAN></FONT>
</BODY>
</HTML>


--B_3198541877_1013967--



Re: Anybody know why this vlan config wont work


sean courtney wrote:
Quoted text here. Click to load it
[cut]

check the trunk encapsulation type on the switch interface f0/1. the
default is isl on older switches supporting this, and you have 802.1q
configured on the router.

on the "show interface f0/1 switchport" output you should see the trunk
encapsulation, ex.:

3500xl#sh int f0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,100,200,201,300
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none
Self Loopback: No

you can change the trunk encapsulation type using:
(config-if)# switchport trunk encapsulation dot1q

--
kris-at-home-dot-pl


Re: Anybody know why this vlan config wont work


I checked, and checked again using your advice.

I think this switch is only capable of .1q encapsulation, but here is the
interface output

Switch#en
Switch#sh int fa0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false

Voice VLAN: none (Inactive)
Appliance trust: none


On 5/10/05 4:39 AM, in article 1hvp5d.0m9.ln@192.168.131.51, "Krzysztof

Quoted text here. Click to load it



Re: Anybody know why this vlan config wont work



Router(config)#int fa0/0
Router(config-if)#no shutdown

Ah the simple things in life!

Alan



Re: Anybody know why this vlan config wont work


hessaacd@yahoo.com wrote:
Quoted text here. Click to load it
While he doesn't actually give us the physical topology, I'd guess from the
addresses that the router port connected to the switch was really F0/1 and that
F0/0 was intentionally shut down.  Since the switch has vlan1 defined as native
and the router does not, they won't pass traffic properly for that vlan.  Try
this:

interface FastEthernet0/1
  no ip address
  duplex auto
  speed auto
!
interface FastEthernet0/1.1
  encapsulation dot1Q 1 native     <<<---add native keyword
  ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/1.10
  encapsulation dot1Q 10
!
interface FastEthernet0/1.20
  encapsulation dot1Q 20



Re: Anybody know why this vlan config wont work


Way too easy,  thanks

Not enough coffee I guess

sean


On 5/10/05 5:35 PM, in article
1115764533.238790.195330@f14g2000cwb.googlegroups.com, "hessaacd@yahoo.com"

Quoted text here. Click to load it



Site Timeline