2611 flash issue..please help ASAP

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
Hi everyone
the issue I am having with this one 2611 is that when it first came in
this is the message I have gotten.

System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)
Copyright (c) 1999 by cisco Systems, Inc.
TAC:Home:SW:IOS:Specials for info
C2600 platform with 32768 Kbytes of main memory

open: file "n" not found
open(): Open Error = -1
loadprog: error - on file open
boot: cannot load "flash:n"

This made me think that the previous IOS was corrupt or missing but
when I did a dir flash: commmand it showed the flash name and
everything.

rommon 1 > dir flash:
         File size           Checksum   File name
   5426208 bytes (0x52cc20)   0x1ad4    c2600-i-mz.122-12a.bin

I resinstalled a new IOS twice so far and what happens is it brings me
into a configuration mode of 0x102. It has a password which is weird
because it should not have one. When I try to recover password using
confreg 0x2142 this is the message that I get.

oh01rtr4>confreg 0x2142
Translating "confreg"...domain server (172.17.16.120)

Most commands do not work and will do the same. show ver does work and
this is the version.

oh01rtr4>show version
Cisco Internetwork Operating System
Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.2(12a), RELEASE
SOFTWARE (fc1)
Copyright (c) 1986-2002 by cisco Systems, Inc.
Compiled Tue 24-Sep-02 01:05 by pwade
Image text-base: 0x8000808C, data-base: 0x809E1544

ROM: System Bootstrap, Version 11.3(2)XA4, RELEASE SOFTWARE (fc1)

oh01rtr4 uptime is 1 minute
System returned to ROM by power-on
System image file is "flash:c2600-i-mz.122-12a.bin"

cisco 2611 (MPC860) processor (revision 0x203) with 24576K/8192K bytes
of memory
.
Processor board ID JAD05290XXG (762432776)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
2 Ethernet/IEEE 802.3 interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x102

oh01rtr4>

I have no idea what else I could do to this thing. If anyone has any
ideas please share.

Thank You

Sincerely
Sam

Re: 2611 flash issue..please help ASAP
Sam,

You are trying to set the configuration register from un-privileged mode,
you cannot do that. You need to force a break on the boot up while connected
via console and set it there. Then reload and the router will boot without
reading the start up config. You can then enable and merge the start-up conf
with running conf. Like So.....

Connect via console and pwr the router up

Hit the break key within 60 seconds of the power-up to put the router into
ROMMON It will look like

ROMMON1>
Type confreg 0x2142 the prompt will change to
ROMMON2>
Type reset

Once it reloads you need to answer "no" to the question above configuring
initial set up

Once you get to the Router> prompt type enable and you should end up with

Router#

You are now past the point where you need the password. You should now type
" copy start run" and you will have the original config back. From here you
should type "conf t" and set the enable password to whatever you like.
 You must then from the enable prompt type "conf t" and then config-register
0x2102

 Of course if you just want a clean router you could do the opposite and
write mem without copying the start up config. This will in effect give you
a factory clean router.

Hope this helps.

Andy







On 29/04/2008 14:55, in article
09f1c304-e5eb-4a01-8650-c778b1e2aec0@a1g2000hsb.googlegroups.com, "Sam"

Quoted text here. Click to load it


Re: 2611 flash issue..please help ASAP
Quoted text here. Click to load it

I tried the whole confreg even while it was booting up. it comes up
with the same cannot open flash n messaage. I am starting to think its
the hardware itself. i tried putting in the flash from a working unit
and it would not load the flash correctly.

Re: 2611 flash issue..please help ASAP
Sam, Forgot to mention, the reason you get the below....

Quoted text here. Click to load it

Is because confreg is a privileged command, hence not recognized at that
level. Because it is an unknown command the router thinks you are trying to
connect to a host called "confreg" and attempts to resolve the name via DNS.

Andy




Re: 2611 flash issue..please help ASAP
On wto, 29 kwi 2008 o 13:55 GMT, Sam wrote:
Quoted text here. Click to load it

http://www.cisco.com/en/US/products/hw/routers/ps259/products_password_recovery09186a0080094675.shtml#procedure

--
pozdr. Slawomir Kawala
JID: slwkk [at] alternatywa [dot] net
GSM: (0)601-398-348

Re: 2611 flash issue..please help ASAP
Quoted text here. Click to load it

This tells us that there is a boot statement and the router is trying to
boot from flash:n

Go do password recovery, and once you've done that, jump into global
config and do:

Router(config)#no boot system
This clears out your boot statement. Now do:
Router(config)#boot system flash:

Save your config and its fixed. Technically, you don't *need* the last
statement, but I use it for good measure.

--William

Site Timeline