Configuring a Linksys Router with a Comcast Cable Modem

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View
i've been frustrated all day...literally 10 hours!  i've been trying to
get a linksys router to work with a comcast cable modem.  i finally
figured it out, so this post is to help anyone who is frustrated and
searching for answers.  hopefully, i will save you some time and
headache.

according to the tech folks at comcast this should have been easy...all
i needed to do was this:

- unplug cable modem
- turn off computer
- disconnect computer from modem (ethernet cable)
- connect computer to router (ethernet cable)
- connect router to modem (ethernet cable)
- plug in cable modem
- wait 15 seconds, plug in router
- wait 15 seconds, reboot computer

according to comcast, it's all dynamic and everything should work
auto-magically.  of course, it didn't...here's what happened:

- the computer got an IP address via DHCP from the router.  i can tell
this by opening a command prompt and typing "ipconfig /all".

- but, the router did not get an IP address via DHCP from the modem.  i
can tell this by opening the linksys admin tool and looking at the
"Internet" section of the the status tab.

so, why wasn't it working?  the answer lies in the "Connection-specific
DNS Suffix" which is configured in the router on the setup tab as
"Domain Name".  what you need to do is this:

1.  go back to your original configuration--modem connected directly to
computer.  (you'll have to shut it all down, etc., so that IPs are
granted properly.)

2.  open an command prompt and type "ipconfig /all".

3.  read what it says for "Connection-specific DNS Suffix", and write
it down.  in my case, that was "hsd1.wa.comcast.net.".  (note the
period after the ".net"...that threw me for a loop because at first i
just entered it as "hsd1.wa.comcast.net", but you gotta do it exactly
the same.)

4.  reconfigure so that your router is between your modem and computer.
(again, do all the proper shutting down and rebooting.) visit the
router admin, setup tab and set the "domain name" to what you wrote
down in step 3.  don't forget to click "apply".

5.  now, visit the status tab in the router admin tool.  click the
"DHCP Renew" button and you should now see your router has been
assigned an IP address via DHCP from the modem.  (well, technically
from the DHCP server via the modem, but whatever.)

so, to summarize: the whole problem here was that when the router and
the modem were connected to each other, but the router was not
providing the "Connection-specific DNS Suffix", then the modem wasn't
assigning an IP address.  to solve that problem, set the "Domain Name"
on the setup tab of the router to the value that the modem was
providing when there was no router in place and click "DHCP Renew" on
the status tab.

I hope this helps,

Scott



Re: Configuring a Linksys Router with a Comcast Cable Modem
Oh, two other handy things to know:

1.  You get to the Linksys Router Admin Tool by hitting
http://192.168.1.1 in your web browser.

2.  On most Cable Modems, you Admin Tool by hitting
http://192.168.100.1 .

In the case where you are computer>router>modem and it's not working
you won't be able to see the Cable Modem Admin Tool.

On the other hand, in the case where you are computer>modem and it is
working you won't be able to see the Linksys Router Admin Tool.

When you finally have it all working, you'll be able to see both just
fine.

One last, slightly off topic point: take about 20 seconds to add a
little security to your Linksys Router network
-- change the device IP address (i.e. #1 above)...it's super easy for
hackers if all they have to do is use the default IP address.
-- on the DHCP tab, limit the number of DHCP connections to the actual
numbe of computers that you have.
-- also on the DHCP tab, set the starting IP address to something
other than x.x.x.100.
-- if you have a Wireless Access Point Router, change the
SSID...again, make it slightly harder for hackers, and
-- also, if you have a WAP, require a WEP key.  (well, there may be
places where you don't want this, like if you're installing it in a
coffee shop for public use.  but, i live in an urban neighborhood and
can connect to any 4 of my neighbor's "linksys" networks wirelessly.
i'm not smart enough to hack into them, but it's pretty obvious that
any hacker could just walk down the street in my neighborhood and do
so.)

also, after each of these steps, you'll most likely need to do an
"ipconfig /release", then "ipconfig /renew" to re-establish the
connection between your computer and the router.

that said, any determined hacker is gonna be able to pass these
measures.  however, it will make it harder for the amateurs, and the
determined guys will probably just move on to a house where the doors
are unlocked, so to speak.

good luck,

scott



Re: Configuring a Linksys Router with a Comcast Cable Modem
scott@porad.com wrote:
> i've been frustrated all day...literally 10 hours!  i've been trying to
> get a linksys router to work with a comcast cable modem.  i finally
> figured it out, so this post is to help anyone who is frustrated and
> searching for answers.  hopefully, i will save you some time and
> headache.
>
> according to the tech folks at comcast this should have been easy...all
> i needed to do was this:
>
> - unplug cable modem
> - turn off computer
> - disconnect computer from modem (ethernet cable)
> - connect computer to router (ethernet cable)
> - connect router to modem (ethernet cable)
> - plug in cable modem
> - wait 15 seconds, plug in router
> - wait 15 seconds, reboot computer
>
> according to comcast, it's all dynamic and everything should work
> auto-magically.  of course, it didn't...here's what happened:
>
> - the computer got an IP address via DHCP from the router.  i can tell
> this by opening a command prompt and typing "ipconfig /all".
>
> - but, the router did not get an IP address via DHCP from the modem.  i
> can tell this by opening the linksys admin tool and looking at the
> "Internet" section of the the status tab.
>
> so, why wasn't it working?  the answer lies in the "Connection-specific
> DNS Suffix" which is configured in the router on the setup tab as
> "Domain Name".  what you need to do is this:
>
> 1.  go back to your original configuration--modem connected directly to
> computer.  (you'll have to shut it all down, etc., so that IPs are
> granted properly.)
>
> 2.  open an command prompt and type "ipconfig /all".
>
> 3.  read what it says for "Connection-specific DNS Suffix", and write
> it down.  in my case, that was "hsd1.wa.comcast.net.".  (note the
> period after the ".net"...that threw me for a loop because at first i
> just entered it as "hsd1.wa.comcast.net", but you gotta do it exactly
> the same.)
>
> 4.  reconfigure so that your router is between your modem and computer.
> (again, do all the proper shutting down and rebooting.) visit the
> router admin, setup tab and set the "domain name" to what you wrote
> down in step 3.  don't forget to click "apply".
>
> 5.  now, visit the status tab in the router admin tool.  click the
> "DHCP Renew" button and you should now see your router has been
> assigned an IP address via DHCP from the modem.  (well, technically
> from the DHCP server via the modem, but whatever.)
>
> so, to summarize: the whole problem here was that when the router and
> the modem were connected to each other, but the router was not
> providing the "Connection-specific DNS Suffix", then the modem wasn't
> assigning an IP address.  to solve that problem, set the "Domain Name"
> on the setup tab of the router to the value that the modem was
> providing when there was no router in place and click "DHCP Renew" on
> the status tab.
>
> I hope this helps,
>
> Scott
>
Scott,
   It is necessary to provide the domain name to the router for  Charter
Pipeline as well.  That is the only thing the user need provide for a
default configuration, but without it, Charter won't talk to the Router.


--
Ron Hunter  rphunter@charter.net


Re: Configuring a Linksys Router with a Comcast Cable Modem
Not with Comcast in Philadelphia.  All you do is plug it in - all default
with no additional settings - and it all works out of the box.


> i've been frustrated all day...literally 10 hours!  i've been trying to
> get a linksys router to work with a comcast cable modem.  i finally
> figured it out, so this post is to help anyone who is frustrated and
> searching for answers.  hopefully, i will save you some time and
> headache.
>
> according to the tech folks at comcast this should have been easy...all
> i needed to do was this:
>
> - unplug cable modem
> - turn off computer
> - disconnect computer from modem (ethernet cable)
> - connect computer to router (ethernet cable)
> - connect router to modem (ethernet cable)
> - plug in cable modem
> - wait 15 seconds, plug in router
> - wait 15 seconds, reboot computer
>
> according to comcast, it's all dynamic and everything should work
> auto-magically.  of course, it didn't...here's what happened:
>
> - the computer got an IP address via DHCP from the router.  i can tell
> this by opening a command prompt and typing "ipconfig /all".
>
> - but, the router did not get an IP address via DHCP from the modem.  i
> can tell this by opening the linksys admin tool and looking at the
> "Internet" section of the the status tab.
>
> so, why wasn't it working?  the answer lies in the "Connection-specific
> DNS Suffix" which is configured in the router on the setup tab as
> "Domain Name".  what you need to do is this:
>
> 1.  go back to your original configuration--modem connected directly to
> computer.  (you'll have to shut it all down, etc., so that IPs are
> granted properly.)
>
> 2.  open an command prompt and type "ipconfig /all".
>
> 3.  read what it says for "Connection-specific DNS Suffix", and write
> it down.  in my case, that was "hsd1.wa.comcast.net.".  (note the
> period after the ".net"...that threw me for a loop because at first i
> just entered it as "hsd1.wa.comcast.net", but you gotta do it exactly
> the same.)
>
> 4.  reconfigure so that your router is between your modem and computer.
> (again, do all the proper shutting down and rebooting.) visit the
> router admin, setup tab and set the "domain name" to what you wrote
> down in step 3.  don't forget to click "apply".
>
> 5.  now, visit the status tab in the router admin tool.  click the
> "DHCP Renew" button and you should now see your router has been
> assigned an IP address via DHCP from the modem.  (well, technically
> from the DHCP server via the modem, but whatever.)
>
> so, to summarize: the whole problem here was that when the router and
> the modem were connected to each other, but the router was not
> providing the "Connection-specific DNS Suffix", then the modem wasn't
> assigning an IP address.  to solve that problem, set the "Domain Name"
> on the setup tab of the router to the value that the modem was
> providing when there was no router in place and click "DHCP Renew" on
> the status tab.
>
> I hope this helps,
>
> Scott
>




Re: Configuring a Linksys Router with a Comcast Cable Modem
Same here with Comcast, Macomb County, Michigan.  Plug'n'play!

Bill Crocker


> Not with Comcast in Philadelphia.  All you do is plug it in - all default
> with no additional settings - and it all works out of the box.
>
>
>> i've been frustrated all day...literally 10 hours!  i've been trying to
>> get a linksys router to work with a comcast cable modem.  i finally
>> figured it out, so this post is to help anyone who is frustrated and
>> searching for answers.  hopefully, i will save you some time and
>> headache.
>>
>> according to the tech folks at comcast this should have been easy...all
>> i needed to do was this:
>>
>> - unplug cable modem
>> - turn off computer
>> - disconnect computer from modem (ethernet cable)
>> - connect computer to router (ethernet cable)
>> - connect router to modem (ethernet cable)
>> - plug in cable modem
>> - wait 15 seconds, plug in router
>> - wait 15 seconds, reboot computer
>>
>> according to comcast, it's all dynamic and everything should work
>> auto-magically.  of course, it didn't...here's what happened:
>>
>> - the computer got an IP address via DHCP from the router.  i can tell
>> this by opening a command prompt and typing "ipconfig /all".
>>
>> - but, the router did not get an IP address via DHCP from the modem.  i
>> can tell this by opening the linksys admin tool and looking at the
>> "Internet" section of the the status tab.
>>
>> so, why wasn't it working?  the answer lies in the "Connection-specific
>> DNS Suffix" which is configured in the router on the setup tab as
>> "Domain Name".  what you need to do is this:
>>
>> 1.  go back to your original configuration--modem connected directly to
>> computer.  (you'll have to shut it all down, etc., so that IPs are
>> granted properly.)
>>
>> 2.  open an command prompt and type "ipconfig /all".
>>
>> 3.  read what it says for "Connection-specific DNS Suffix", and write
>> it down.  in my case, that was "hsd1.wa.comcast.net.".  (note the
>> period after the ".net"...that threw me for a loop because at first i
>> just entered it as "hsd1.wa.comcast.net", but you gotta do it exactly
>> the same.)
>>
>> 4.  reconfigure so that your router is between your modem and computer.
>> (again, do all the proper shutting down and rebooting.) visit the
>> router admin, setup tab and set the "domain name" to what you wrote
>> down in step 3.  don't forget to click "apply".
>>
>> 5.  now, visit the status tab in the router admin tool.  click the
>> "DHCP Renew" button and you should now see your router has been
>> assigned an IP address via DHCP from the modem.  (well, technically
>> from the DHCP server via the modem, but whatever.)
>>
>> so, to summarize: the whole problem here was that when the router and
>> the modem were connected to each other, but the router was not
>> providing the "Connection-specific DNS Suffix", then the modem wasn't
>> assigning an IP address.  to solve that problem, set the "Domain Name"
>> on the setup tab of the router to the value that the modem was
>> providing when there was no router in place and click "DHCP Renew" on
>> the status tab.
>>
>> I hope this helps,
>>
>> Scott
>>
>
>




Re: Configuring a Linksys Router with a Comcast Cable Modem
scott@porad.com wrote:
>
> - but, the router did not get an IP address via DHCP from the modem.
> i
> can tell this by opening the linksys admin tool and looking at the
> "Internet" section of the the status tab.
>
> so, why wasn't it working?  the answer lies in the
> "Connection-specific
> DNS Suffix" which is configured in the router on the setup tab as
> "Domain Name".  what you need to do is this:
>

Um... No.

The DNS suffix is what is added to a url when there is no entry in the
table on the DNS server. For example, with what you put in that field,
if you were to type "go-here" in the address bar of your browser, when
"go-here" is not found on the DNS server, "go-here.hsd1.wa.comcast.net."
would be tried.

The setting you've indicated does *nothing* when the router is
attempting to acquire an IP address.

Most likely what happened was the DHCP server was down when you first
tried to connect, but came up just after you made the change in how the
router will resolved failed DNS.

The process in a nutshell is to disconnect the power from the modem and
the router. Reconnect the power to the router, and wait until it
acquires sync. (This can best be described as the lights stabilize.)
Normally that shouldn't take more than 15 or 20 seconds, but could take
longer. (Perhaps another reason why your early attempts failed is you
didn't wait for the modem to get sync before moving on.)

Only after the modem is sync'd should you power-up the router (with
factory default settings). Most routers will sync up much faster -
usually within 1 or 2 seconds. Sometimes so fast that you don't notice
the difference between the light pattern during sync up, and a stable
light pattern.

The last step is to boot your computer.

Under the old @Home network, and with some other ISP's (not Comcast) you
may need to add in the DNS suffix setting because server names, like the
mail and new settings, they give out are generic, incomplete names that
anyone in any region can use. The DNS suffix then adds the regional
sub-domain to the incomplete name to get you to the right server. But
none of that works until *after* DHCP has completed.

Other ISP's, including the old @Home network, required a specific
username, or computer name. This would be the case if DHCP is by
computer name instead of MAC address. That's not the case on Comcast
either.

Putting things in any of those fields will have no effect on whether or
not you get connected on Comcast. A computer name or username will have
zero effect, but putting something incorrect in the DNS suffix field may
result in longer periods of time before DNS resolution fails when the
name cannot be found. But again, it doesn't make any difference until
*after* you're connected.

Remember, to the Comcast network, your router looks like just another
computer connected to the network. It needs no additional settings
beyond what a computer would need. There are no special settings that
routers need. On some systems, the network may not recognize the new MAC
address of the router, and a phone call to support is needed. But even
that's not the case on Comcast, as new MAC addresses are automatically
acquired. You just need to make sure you power-cycle the modem to
trigger this process.

--
Warren H.

==========
Disclaimer: My views reflect those of myself, and not my
employer, my friends, nor (as she often tells me) my wife.
Any resemblance to the views of anybody living or dead is
coincidental. No animals were hurt in the writing of this
response -- unless you count my dog who desperately wants
to go outside now.
     Compare the newest tax preparation software apps:
      http://www.holzemville.com/mall/taxes/index.html





Re: Configuring a Linksys Router with a Comcast Cable Modem
scott@porad.com wrote:
> i've been frustrated all day...literally 10 hours!  i've been trying to
> get a linksys router to work with a comcast cable modem.  i finally
> figured it out, so this post is to help anyone who is frustrated and
> searching for answers.  hopefully, i will save you some time and
> headache.
>
> according to the tech folks at comcast this should have been easy...all
> i needed to do was this:
>
> - unplug cable modem
> - turn off computer
> - disconnect computer from modem (ethernet cable)
> - connect computer to router (ethernet cable)
> - connect router to modem (ethernet cable)
> - plug in cable modem
> - wait 15 seconds, plug in router
> - wait 15 seconds, reboot computer

You have to wait 50 seconds, not 15; and remember it is power that must
be unplugged.


> according to comcast, it's all dynamic and everything should work
> auto-magically.  of course, it didn't...here's what happened:

True with Win xp.

> - the computer got an IP address via DHCP from the router.  i can tell
> this by opening a command prompt and typing "ipconfig /all".

Correct.

> - but, the router did not get an IP address via DHCP from the modem.  i
> can tell this by opening the linksys admin tool and looking at the
> "Internet" section of the the status tab.

>
> so, why wasn't it working?  the answer lies in the "Connection-specific
> DNS Suffix" which is configured in the router on the setup tab as
> "Domain Name".  what you need to do is this:
>
> 1.  go back to your original configuration--modem connected directly to
> computer.  (you'll have to shut it all down, etc., so that IPs are
> granted properly.)
>
> 2.  open an command prompt and type "ipconfig /all".
>
> 3.  read what it says for "Connection-specific DNS Suffix", and write
> it down.  in my case, that was "hsd1.wa.comcast.net.".  (note the
> period after the ".net"...that threw me for a loop because at first i
> just entered it as "hsd1.wa.comcast.net", but you gotta do it exactly
> the same.)
>
> 4.  reconfigure so that your router is between your modem and computer.
> (again, do all the proper shutting down and rebooting.) visit the
> router admin, setup tab and set the "domain name" to what you wrote
> down in step 3.  don't forget to click "apply".
>
> 5.  now, visit the status tab in the router admin tool.  click the
> "DHCP Renew" button and you should now see your router has been
> assigned an IP address via DHCP from the modem.  (well, technically
> from the DHCP server via the modem, but whatever.)
>

Plug the modem into the WAN port.



Site Timeline