Comcast DHCP renewal problem?

Have a question or want to start a discussion? Post it! No Registration Necessary.  Now with pictures!

Threaded View


Greetings.

I have a Motorola SB4100, which has been very reliable for my basic tier
Comcast service.

In the past few months, I have experienced a problem where web pages
will time out on first loading.  They will usually work after selecting
reload.  Each time this has occurred, I check the modem's log, and
always find this (latest example shown):

060302073149     5-Warning     D103.0     DHCP RENEW WARNING - Field
invalid in response
060302073149     4-Error     D530.8     DHCP - Invalid Log Server IP
Address.
060228133141     5-Warning     D103.0     DHCP RENEW WARNING - Field
invalid in response
060228133141     4-Error     D530.8     DHCP - Invalid Log Server IP
Address.
060225013141     5-Warning     D103.0     DHCP RENEW WARNING - Field
invalid in response
060225013141     4-Error     D530.8     DHCP - Invalid Log Server IP
Address.
060221185030     8-Debug     M570.2     Motorola CM certificate present
060221185030     8-Debug     M571.7     CM Cert Upgrade Enabled.
Initiate after Registration
060221185030     8-Debug     I503.0     Cable Modem is OPERATIONAL

Note that in the earliest entries (Feb 21 2006), all is well.
On Feb 25, the DHCP lease apparently expires (my router confirms that
the current lease is for 4 days, 0 hours), and access starts to suffer.  
Why it even works at all with an expired lease, I can't say.
Anyone else encountering this?

Thanks,

--Gene



Re: Comcast DHCP renewal problem?


Gene,
Me too.

Can you do an ipconfig /all on your PC when your down and post what it
says?
Also where in the country are you located?  I'm in Trenton, NJ
Here is my issue...which is very similiar to your's



I'm experiencing the following problem, I have tried changing out my
cable modem (motorla) and my router (linksys)  and the problem
continues (all firmware is up to date, all the router's MAC address
is cloned as it should be).  I will be surfing the internet and then
all of a sudden the pages will say "request has timed out".  I have
two computers (Tablet PC and Mac OS 10.4.) The internet will go out the
same way on both at the same time.  Now I also have a samba file server
which works fine, but when the internet goes out, I notice the samba
server which is a mapped drive on the PC says it is unavailable, but on
the Mac the samba server is fine and I can use it even when the
Internet goes down.
When the internet is out, I also can't ping the router or the modem,
or use the web-based interface for either, yet my ISP (Comcast) can
ping the router and says all is fine.

I have run the ipconfig on the PC and when the internet works, it all
looks normal, but when it the internet goes down, I get the following:

Autoconfig Ip address - a public IP but isn't the router IP
(normally I get a private IP from my scope when the internet is
working)
The subnet mask will be 255.255.0.0 (normally it is 255.255.255.0)
Default Gateway - nothing (which is of course why I don't have
internet access).

I tried release and renew and that does nothing.  If I turn off the
computer, router, and modem. And then turn on router, modem, and then
computer (in that order) it all works again.
The only message that appears in the modem log during this is
"DHCP RENEW WARNING - Field invalid in response", a warning not an
error message.


Re: Comcast DHCP renewal problem?


first.last@comcast.net says...
Quoted text here. Click to load it

I got the firmware update for my router (Netgear WGR614v6).
Interestingly, it would not install (I got a "memory allocation error").
I reset the router to factory defaults, and was then able to install the
update.  One of the items fixed by the update involved "DHCP renewal".

Service is working fine, for now.  I'll just wait for the current lease
to expire and see what happens.

--Gene

Re: Comcast DHCP renewal problem?


first.last@comcast.net says...
Quoted text here. Click to load it

Well, it's still broken.  The SB4100 is unable to get a new DHCP lease
when the current one expires:

060313211741     1-Emergency     D522.0     DHCP Lease Expired.
060313001756     4-Error     D102.0     DHCP REBIND sent - no response
060313001756     5-Warning     D521.0     DHCP Lease Renewal Failure.
060313001751     4-Error     D102.0     DHCP REBIND sent - no response
060313001751     5-Warning     D521.0     DHCP Lease Renewal Failure.
060313001746     4-Error     D102.0     DHCP REBIND sent - no response
060313001746     5-Warning     D521.0     DHCP Lease Renewal Failure.
060313001741     5-Warning     D523.0     DHCP Rebinding Timer Event.
060310091755     4-Error     D101.0     DHCP RENEW sent - no response
060310091755     5-Warning     D521.0     DHCP Lease Renewal Failure.
060310091750     4-Error     D101.0     DHCP RENEW sent - no response
060310091750     5-Warning     D521.0     DHCP Lease Renewal Failure.
060310091745     4-Error     D101.0     DHCP RENEW sent - no response
060310091745     5-Warning     D521.0     DHCP Lease Renewal Failure.

If I power cycle the modem, everything works, although it takes a few
tries to get a lease:


060313212326     8-Debug     I503.0     Cable Modem is OPERATIONAL
060313212326     7-Information     B401.0     Authorized
060313212325     8-Debug     F502.1     Bridge Forwarding Enabled.
060313212325     8-Debug     F502.3     Bridge Learning Enabled.
060313212325     7-Information     B0.0     Baseline Privacy
060313212323     7-Information     X518.9     Configuration - MMFMMD -
Unit Update Enabled by CVC
060313212323     8-Debug     I500.1     DOCSIS 1.0 Registration
Completed
060313212323     7-Information     I500.4     Attempting DOCSIS 1.0
Registration
060313212323     7-Information     D509.0     Retrieved TFTP Config File
SUCCESS
060313212323     7-Information     D507.0     Retrieved Time.......
SUCCESS
7-Information D511.0 Retrieved DHCP .......... SUCCESS
5-Warning D3.0 DHCP WARNING - Non-critical field invalid in response
4-Error D530.8 DHCP - Invalid Log Server IP Address.
5-Warning D520.2 DHCP Attempt# 4 BkOff: 5s Tot DSC:4 OFF:1 REQ:1 ACK:1
3-Critical D1.0     DHCP FAILED - Discover sent, no offer received
5-Warning D520.2 DHCP Attempt# 2 BkOff: 5s Tot DSC:2 OFF:0 REQ:0 ACK:0
3-Critical     D1.0     DHCP FAILED - Discover sent, no offer received
5-Warning D520.2 DHCP Attempt# 1 BkOff: 4s Tot DSC:1 OFF:0 REQ:0 ACK:0
3-Critical     D1.0     DHCP FAILED - Discover sent, no offer received
7-Information D0.0     DHCP CM Net Configuration download and Time of Day
7-Information     T500.0     Acquired Upstream .......... SUCCESS
8-Debug T503.1 Acquire US with status OK, powerLevel 36, tempSid 5128
8-Debug T505.0 Acquired Upstream with status OK
7-Information T501.0 Acquired Downstream (693000000 Hz)........ SUCCESS
8-Debug T509.0 Acquired DS with status OK, DS Freq 693000000, US Id 4
7-Information I510.0     *** BOOTING *** SB4100-1.4.9.0-SCM00-NOSH

This is a fairly recent behavior; anyone else encountering it?

--Gene

Site Timeline